summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFilipe Brandenburger <filbranden@google.com>2014-06-16 20:54:50 -0700
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-06-20 18:44:40 -0400
commitbe8737ae386166d2f279767ac87b226204c0de7e (patch)
tree054472d47c1ff586bd6a95a79dcbe1b2dafd1c59 /configure.ac
parent49100d2abd1fc7ff36287de8c2645d37068784c2 (diff)
build-sys: add verbosity to python-lxml detection in ./configure
Be verbose when checking if Python module lxml is available. Also warn that Python support will be disabled when the lxml module is not present. Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=80005 Tested: - Without python-lxml package installed: $ ./configure checking for python extension module directory... ${exec_prefix}/lib64/python2.7/site-packages checking for python lxml module... no configure: WARNING: *** python support requires python-xml module installed - With python-lxml package installed: $ ./configure checking for python extension module directory... ${exec_prefix}/lib64/python2.7/site-packages checking for python lxml module... yes checking for PYTHON_DEVEL... yes ... Python: yes Python Headers: yes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1391d033b..1aff72d3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -216,8 +216,13 @@ AC_ARG_WITH([python],
have_lxml=no
AS_IF([test "x$with_python" != "xno"], [
AM_PATH_PYTHON(,, [:])
- AS_IF(["$PYTHON" -c 'import lxml' 2>/dev/null], [have_lxml=yes], [have_lxml=no])
- AS_IF([test "$PYTHON" != : -a $have_lxml = yes], [have_python=yes])
+ AS_IF([test "x$PYTHON" != "x:"], [
+ AC_MSG_CHECKING([for python lxml module])
+ AS_IF(["$PYTHON" -c 'import lxml' 2>/dev/null], [have_lxml=yes])
+ AC_MSG_RESULT([$have_lxml])
+ AS_IF([test "x$have_lxml" = "xyes"], [have_python=yes],
+ [AC_MSG_WARN([*** python support requires python-lxml module installed])])
+ ])
])
AM_CONDITIONAL([HAVE_PYTHON], [test "x$have_python" = "xyes"])
AS_IF([test "x$PYTHON_BINARY" = "x"],