summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-04-20 22:08:33 +0200
committerAndy Wingo <wingo@pobox.com>2015-04-20 22:08:33 +0200
commitc02074a32b77dd9a1166b9d86181bb387a3431ac (patch)
tree67752c6357ba57db03e208ede4613124ba35e819 /configure.ac
parent3559aa12c65a871824d925257531585a38e51f77 (diff)
Disable -flto
With binutils 2.25, the following error occurred: /tmp/ccx3cAlA.ltrans10.ltrans.o: In function `bus_error_name_to_errno.5271': /home/wingo/src/elogind/src/libelogind/sd-bus/bus-error.c:113: undefined reference to `__stop_BUS_ERROR_MAP' /home/wingo/src/elogind/src/libelogind/sd-bus/bus-error.c:113: undefined reference to `__start_BUS_ERROR_MAP' collect2: error: ld returned 1 exit status
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 8c37ca3a7..b8351f397 100644
--- a/configure.ac
+++ b/configure.ac
@@ -191,11 +191,11 @@ AS_CASE([$CC], [*clang*],
-Wno-gnu-variable-sized-type-not-at-end \
])])
-AS_CASE([$CFLAGS], [*-O[[12345sz\ ]]*],
- [CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
- -flto -ffat-lto-objects])],
- [AC_MSG_RESULT([skipping -flto, optimization not enabled])])
-AC_SUBST([OUR_CFLAGS], "$with_cflags $sanitizer_cflags")
+dnl AS_CASE([$CFLAGS], [*-O[[12345sz\ ]]*],
+dnl [CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
+dnl -flto -ffat-lto-objects])],
+dnl [AC_MSG_RESULT([skipping -flto, optimization not enabled])])
+dnl AC_SUBST([OUR_CFLAGS], "$with_cflags $sanitizer_cflags")
AS_CASE([$CFLAGS], [*-O[[12345sz\ ]]*],
[CC_CHECK_FLAGS_APPEND([with_cppflags], [CPPFLAGS], [\