summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@gmail.com>2014-08-27 18:31:34 +0200
committerDavid Herrmann <dh.herrmann@gmail.com>2014-08-27 18:42:28 +0200
commitc93e5a62ff599528c3bf2a8656825403aaebe093 (patch)
tree4aed2f2ccaad553397e60d68851b5fdc80307d6e /configure.ac
parente202fa31fb2d60084e7b2ab7976a81c138184d40 (diff)
terminal: add evdev elements to idev
The evdev-element provides linux evdev interfaces as idev-elements. This way, all real input hardware devices on linux can be used with the idev interface. We use libevdev to interface with the kernel. It's a simple wrapper library around the kernel evdev API that takes care to resync devices after kernel-queue overflows, which is a rather non-trivial task. Furthermore, it's a well tested interface used by all other major input users (Xorg, weston, libinput, ...). Last but not least, it provides nice keycode to keyname lookup tables (and vice versa), which is really nice for debugging input problems.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 08a8a105f..3900c4065 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1066,8 +1066,11 @@ AM_CONDITIONAL(ENABLE_MULTI_SEAT_X, [test "$have_multi_seat_x" = "yes"])
have_terminal=no
AC_ARG_ENABLE(terminal, AS_HELP_STRING([--enable-terminal], [enable terminal support]))
if test "x$enable_terminal" = "xyes"; then
- AC_DEFINE(ENABLE_TERMINAL, 1, [Define if terminal support is to be enabled])
- have_terminal=yes
+ PKG_CHECK_MODULES([TERMINAL], [ libevdev >= 1.2 ], [have_terminal=yes])
+ AS_IF([test "x$have_terminal" != xyes -a "x$enable_terminal" = xyes],
+ [AC_MSG_ERROR([*** terminal support requested but required dependencies not available])],
+ [test "x$have_terminal" = xyes],
+ [AC_DEFINE(ENABLE_TERMINAL, 1, [Define if terminal support is to be enabled])])
fi
AM_CONDITIONAL(ENABLE_TERMINAL, [test "x$have_terminal" = "xyes"])