summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Scherer <misc@zarb.org>2014-02-20 16:19:44 +0100
committerLennart Poettering <lennart@poettering.net>2014-02-21 03:44:20 +0100
commiteef65bf3ee6f73afa4a5de23ae3a794a279f30c0 (patch)
tree366b91cc8b993595fec85469317e1351c98d8ee7 /configure.ac
parent37f78db2f4a33474fc349f406b0a0a48e9c573a2 (diff)
core: Add AppArmor profile switching
This permit to switch to a specific apparmor profile when starting a daemon. This will result in a non operation if apparmor is disabled. It also add a new build requirement on libapparmor for using this feature.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c03a0e26b..80c14493e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -385,6 +385,21 @@ if test "x$enable_selinux" != "xno"; then
fi
AM_CONDITIONAL(HAVE_SELINUX, [test "$have_selinux" = "yes"])
+have_apparmor=no
+AC_ARG_ENABLE(apparmor, AS_HELP_STRING([--disable-apparmor], [Disable optional AppArmor support]))
+if test "x$enable_apparmor" != "xno"; then
+ PKG_CHECK_MODULES([APPARMOR], [libapparmor],
+ [AC_DEFINE(HAVE_APPARMOR, 1, [Define if AppArmor is available])
+ have_apparmor=yes
+ M4_DEFINES="$M4_DEFINES -DHAVE_APPARMOR"],
+ [have_apparmor=no])
+ if test "x$have_apparmor" = xno -a "x$enable_apparmor" = xyes; then
+ AC_MSG_ERROR([*** AppArmor support requested but libraries not found])
+ fi
+fi
+AM_CONDITIONAL(HAVE_APPARMOR, [test "$have_apparmor" = "yes"])
+
+
AC_ARG_WITH(debug-shell,
AS_HELP_STRING([--with-debug-shell=PATH],
[Path to debug shell binary]),
@@ -1110,6 +1125,7 @@ AC_MSG_RESULT([
PAM: ${have_pam}
AUDIT: ${have_audit}
IMA: ${have_ima}
+ AppArmor: ${have_apparmor}
SELinux: ${have_selinux}
SECCOMP: ${have_seccomp}
SMACK: ${have_smack}