summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-01-02 17:07:00 +0100
committerLennart Poettering <lennart@poettering.net>2012-01-03 21:08:57 +0100
commit4de856120f252e7aa19c923c10fbf23310d623aa (patch)
tree9b38156f266c7e3731de8e27de227c923ec427d2 /configure.ac
parent776a564f54dd54c7c4e2b2d865e8f9e7ee5404f3 (diff)
build-sys: make quotacheck and randomseed optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f03f6330..0316ad124 100644
--- a/configure.ac
+++ b/configure.ac
@@ -330,6 +330,20 @@ if test "x$enable_readahead" != "xno"; then
fi
AM_CONDITIONAL(ENABLE_READAHEAD, [test "$have_readahead" = "yes"])
+have_quotacheck=no
+AC_ARG_ENABLE(quotacheck, AS_HELP_STRING([--disable-quotacheck], [disable quotacheck tools]))
+if test "x$enable_quotacheck" != "xno"; then
+ have_quotacheck=yes
+fi
+AM_CONDITIONAL(ENABLE_QUOTACHECK, [test "$have_quotacheck" = "yes"])
+
+have_randomseed=no
+AC_ARG_ENABLE(randomseed, AS_HELP_STRING([--disable-randomseed], [disable randomseed tools]))
+if test "x$enable_randomseed" != "xno"; then
+ have_randomseed=yes
+fi
+AM_CONDITIONAL(ENABLE_RANDOMSEED, [test "$have_randomseed" = "yes"])
+
have_logind=no
AC_ARG_ENABLE(logind, AS_HELP_STRING([--disable-logind], [disable login daemon]))
if test "x$enable_logind" != "xno"; then
@@ -627,6 +641,8 @@ AC_MSG_RESULT([
binfmt: ${have_binfmt}
vconsole: ${have_vconsole}
readahead: ${have_readahead}
+ quotacheck: ${have_quotacheck}
+ randomseed: ${have_randomseed}
logind: ${have_logind}
hostnamed: ${have_hostnamed}
timedated: ${have_timedated}