summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@frugalware.org>2011-08-02 23:58:46 +0200
committerLennart Poettering <lennart@poettering.net>2011-08-24 16:03:59 +0200
commitf47cd184c0ff80e025428e9e385e61bda1ef3d69 (patch)
tree95253f57c7289170e5537250662c6c698fe59198 /configure.ac
parenta5afffa151b9969bfb138c409c6092ce12fba340 (diff)
build-sys: Add --disable-timedated configure switch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fbd2ecb56..2795d6cb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -310,6 +310,13 @@ if test "x$enable_hostnamed" != "xno"; then
fi
AM_CONDITIONAL(ENABLE_HOSTNAMED, [test "$have_hostnamed" = "yes"])
+have_timedated=no
+AC_ARG_ENABLE(timedated, AS_HELP_STRING([--disable-timedated], [disable timedate daemon]))
+if test "x$enable_timedated" != "xno"; then
+ have_timedated=yes
+fi
+AM_CONDITIONAL(ENABLE_TIMEDATED, [test "$have_timedated" = "yes"])
+
have_gtk=no
AC_ARG_ENABLE(gtk, AS_HELP_STRING([--disable-gtk], [disable GTK tools]))
if test "x$enable_gtk" != "xno"; then
@@ -572,6 +579,7 @@ AC_MSG_RESULT([
ACL: ${have_acl}
binfmt: ${have_binfmt}
hostnamed: ${have_hostnamed}
+ timedated: ${have_timedated}
plymouth: ${have_plymouth}
prefix: ${prefix}
root dir: ${with_rootdir}