summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndreas Messer <andi@bastelmap.de>2018-01-08 20:45:31 +0100
committerAndreas Messer <andi@bastelmap.de>2018-01-08 20:45:31 +0100
commit6cd13f4e72e44d1325cf2263e6321daa2783c463 (patch)
tree0c315380c0f47da9863207c795e22fe2061094db /debian
parent2ca2fd87c36d84bc47861088f2cd582bdf3e2562 (diff)
Fix dependencies for Debian
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules5
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index a9afbde36..7cdb8ea31 100644
--- a/debian/control
+++ b/debian/control
@@ -19,7 +19,7 @@ Build-Depends: debhelper (>= 9),
gtk-doc-tools,
python3-lxml,
libcap-dev,
- libeudev-dev,
+ libudev-dev,
libmount-dev (>= 2.20),
libseccomp-dev (>= 1.0),
libblkid-dev (>= 2.24),
@@ -36,12 +36,14 @@ Multi-Arch: foreign
Pre-Depends: debconf, ${misc:Pre-Depends}
Depends: ${shlibs:Depends},
${misc:Depends},
+ libudev1,
libelogind0 (= ${binary:Version}),
libpam-elogind (= ${binary:Version}),
lsb-base (>= 3.1),
dbus (>= 1.4)
Recommends: policykit-1
Conflicts: openrc
+Provides: logind
Description: user, seat and session management daemon
elogind is a session management daemon extracted from systmd project's
"logind"
diff --git a/debian/rules b/debian/rules
index 778efce39..fa9fc3972 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,5 +25,10 @@ override_dh_auto_configure:
override_dh_missing:
dh_missing --list-missing
+override_dh_shlibdeps:
+ dh_shlibdeps -- -xlibeudev1
+
+
+
%:
dh $@ --builddirectory=build --with autoreconf --parallel