summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2012-08-08 19:00:35 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2012-08-08 19:22:23 +0200
commit27a7a46429b889fe6835016638e798e5f94dd215 (patch)
tree416b163f8a66fac1dca2c909f0799cb5059f4548 /docs
parent5aea932fd54db835b77709ddeba30732648aae53 (diff)
build-sys: really override CFLAGS for gtk-doc
In 29a00c41 an override was added, but commandline variables have higher precedence than Makefile variables, so the override was not effective for commandline variables. While at it, duplicate for libudev.
Diffstat (limited to 'docs')
-rw-r--r--docs/gudev/Makefile.am4
-rw-r--r--docs/libudev/Makefile.am8
2 files changed, 10 insertions, 2 deletions
diff --git a/docs/gudev/Makefile.am b/docs/gudev/Makefile.am
index 152cd3c01..55172f2c3 100644
--- a/docs/gudev/Makefile.am
+++ b/docs/gudev/Makefile.am
@@ -77,8 +77,8 @@ expand_content_files=
# be listed only once.
# Kill CFLAGS here because gtk-doc thinks adding CFLAGS to CC _and_ also
# adding CFLAGS itself again would work.
-CFLAGS=
-LDFLAGS=
+override CFLAGS=
+override LDFLAGS=
# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
# Only needed if you are using gtkdoc-scangobj to dynamically query widget
diff --git a/docs/libudev/Makefile.am b/docs/libudev/Makefile.am
index f9365b3fd..13e448ace 100644
--- a/docs/libudev/Makefile.am
+++ b/docs/libudev/Makefile.am
@@ -72,6 +72,14 @@ content_files = version.xml
# e.g. expand_content_files=running.sgml
expand_content_files=
+# Hack, hack. You silly gtk-doc, you must not add CFLAGS multiple
+# times when calling gcc; it surely can not work with options that must
+# be listed only once.
+# Kill CFLAGS here because gtk-doc thinks adding CFLAGS to CC _and_ also
+# adding CFLAGS itself again would work.
+override CFLAGS=
+override LDFLAGS=
+
# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
# Only needed if you are using gtkdoc-scangobj to dynamically query widget
# signals and properties.