summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authoruserwithuid <userwithuid@gmail.com>2017-08-09 13:41:44 +0000
committerSven Eden <yamakuzure@gmx.net>2017-08-10 10:29:08 +0200
commitb493a2aa6a2d71e303e8fbd52cb17858afd07db7 (patch)
treede437d52418a4f4c13d0963b997204b7ab96611d /man/meson.build
parente11de0cc371a9a358eeb9dcbb088e308cd4033fb (diff)
build-sys: fix invalid args detected by meson 0.42 (#6561)
some run_target() calls were using params from custom_target() example message: WARNING: Passed invalid keyword argument "input". This will become a hard error in the future. New way to call targets: ninja man/man ninja man/html ninja man/update-man-rules
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/man/meson.build b/man/meson.build
index 8fdb512f6..ea1227f2c 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -178,10 +178,10 @@ man = custom_target(
depends : man_pages,
command : ['echo'])
-html = run_target(
+html = custom_target(
'html',
- depends : html_pages,
output : 'html',
+ depends : html_pages,
command : ['echo'])
#if 0 /// UNNEEDED in elogind
@@ -201,8 +201,9 @@ html = run_target(
############################################################
if git.found()
- run_target(
+ custom_target(
'update-man-rules',
+ output : 'update-man-rules',
# slightly strange syntax because of
# https://github.com/mesonbuild/meson/issues/1643
# and https://github.com/mesonbuild/meson/issues/1512