summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-11-24 14:00:29 +0100
committerSven Eden <yamakuzure@gmx.net>2017-11-24 14:00:29 +0100
commit796d93f5681f2f304db7d9e1d752abaf64c7ff94 (patch)
treea96db7a701b93fe7d4083e3588cd16f8cee08217 /man
parent6f8ee40d684e4c02211a80c3fa8a8a1e694693af (diff)
meson: restore building of man pages on demand even if -Dman=false
I want to configure -Dman=false for speed, but be able to build a specific man page sometimes to check my edits. Commit 5b316b9ea6c broke this by mistake. Let's adjust the condition to better match the logic of disabling tests only if xsltproc is really not found.
Diffstat (limited to 'man')
-rw-r--r--man/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/man/meson.build b/man/meson.build
index 0312f337c..c64a50112 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -34,7 +34,7 @@ xslt_cmd = [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags
man_pages = []
html_pages = []
source_xml_files = []
-foreach tuple : want_man or want_html ? manpages : []
+foreach tuple : xsltproc.found() ? manpages : []
stem = tuple[0]
section = tuple[1]
aliases = tuple[2]