summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2017-10-31 17:12:13 +0900
committerSven Eden <yamakuzure@gmx.net>2017-10-31 17:12:13 +0900
commit91e69bea9385aa573c1d03989548c42fb3f06a7f (patch)
treeaf282c8bc9274f330df3f25585a7c28be52e32a7 /man
parentbe1d8c84ebe7d240e06df26176ac98d91b37fd79 (diff)
meson: do not include man/meson.build if xsltproc not found
Fixes #7232.
Diffstat (limited to 'man')
-rw-r--r--man/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/man/meson.build b/man/meson.build
index d5e4e9089..0312f337c 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -34,7 +34,7 @@ xslt_cmd = [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags
man_pages = []
html_pages = []
source_xml_files = []
-foreach tuple : manpages
+foreach tuple : want_man or want_html ? manpages : []
stem = tuple[0]
section = tuple[1]
aliases = tuple[2]
@@ -121,8 +121,8 @@ elogind_index_xml = custom_target(
output : 'elogind.index.xml',
command : [make_man_index_py, '@OUTPUT@'] + nonindex_xml_files)
-foreach tuple : [['elogind.directives', '7', elogind_directives_xml],
- ['elogind.index', '7', elogind_index_xml]]
+foreach tuple : want_man or want_html ? [['elogind.directives', '7', elogind_directives_xml],
+ ['elogind.index', '7', elogind_index_xml]] : []
stem = tuple[0]
section = tuple[1]
xml = tuple[2]