summaryrefslogtreecommitdiff
path: root/man
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2018-03-26 18:22:06 +0200
committerSven Eden <yamakuzure@gmx.net>2018-03-26 18:26:12 +0200
commitf54f5cd0dde625f9f7d9e89abb24414f2592fa2e (patch)
tree5508fae7f3ea86ceae5f82bb156747d4c551d491 /man
parent3bca3ce937e45e811eb4a264826075e7c0e9228a (diff)
Prep v236: Adapt elogind parts in the build system to upstream changes.
Diffstat (limited to 'man')
-rw-r--r--man/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/man/meson.build b/man/meson.build
index b40a97dba..32bd1b814 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -91,7 +91,12 @@ foreach tuple : xsltproc.found() ? manpages : []
output : htmlalias,
command : ['ln', '-fs', html, '@OUTPUT@'])
if want_html
- dst = join_paths(docdir, 'html', htmlalias)
+#if 0 /// This must be configurable in elogind
+# dst = join_paths(docdir, 'html', htmlalias)
+#else
+ dst = get_option('htmldir')
+ dst = dst != '' ? dst: join_paths(docdir, 'html', htmlalias)
+#endif // 0
cmd = 'ln -fs @0@ $DESTDIR@1@'.format(html, dst)
meson.add_install_script('sh', '-c', cmd)
p2 += [link]