summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-08-19 19:11:30 +0200
committerSven Eden <yamakuzure@gmx.net>2018-09-26 07:45:58 +0200
commit0fcb473bf4815c1d5fc2ea6051d7272571b9df2b (patch)
treef6df53be7861271d05d300893227e091c8d78af1 /meson.build
parent612bbecd2f2904be8ecb84f03a5bad3fff05a467 (diff)
meson: rename -Ddebug to -Ddebug-extra
Meson added -Doptimization and -Ddebug options, which obviously causes a conflict with our -Ddebug options. Let's rename it. Fixes #76.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0d096d847..8b62c789e 100644
--- a/meson.build
+++ b/meson.build
@@ -895,7 +895,7 @@ enable_debug_mmap_cache = false
#if 1 /// additional elogind debug mode
enable_debug_elogind = false
#endif // 1
-foreach name : get_option('debug')
+foreach name : get_option('debug-extra')
if name == 'hashmap'
enable_debug_hashmap = true
elif name == 'mmap-cache'