summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2018-08-27 08:44:24 +0200
committerSven Eden <yamakuzure@gmx.net>2018-08-27 09:10:27 +0200
commit9d814db96b6f093fc334f60fa7c97fb3ce9852a8 (patch)
tree55b4d63a303ca27c69816c58f3d731bf16f28c39 /meson.build
parentc552a8e6e51f69d5afc5deb724fd9ae184a4fbe7 (diff)
Prep v239: A few cosmetic upgrades
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index cdb4dedc8..93a108000 100644
--- a/meson.build
+++ b/meson.build
@@ -1442,6 +1442,19 @@ conf.set10('ENABLE_EFI', have)
#####################################################################
+#if 1 /// These are not needed by elogind, but meson wants them although they are commented out.
+conf.set_quoted('CERTIFICATE_ROOT', '/dev/null')
+conf.set_quoted('MEMORY_ACCOUNTING_DEFAULT_YES_NO', 'N/A')
+conf.set_quoted('MOUNT_PATH', '/dev/null')
+conf.set_quoted('SYSTEM_ENV_GENERATOR_PATH', '/dev/null')
+conf.set_quoted('SYSTEM_GENERATOR_PATH', '/dev/null')
+conf.set_quoted('UMOUNT_PATH', '/dev/null')
+conf.set_quoted('USER_ENV_GENERATOR_PATH', '/dev/null')
+conf.set_quoted('USER_GENERATOR_PATH', '/dev/null')
+#####################################################################
+
+#endif // 1
+
config_h = configure_file(
output : 'config.h',
configuration : conf)