summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-05-03 18:07:43 +0900
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commitdce6bf50cb716938ab0caf3efd2bf505dc7b091e (patch)
tree006e5297304d33bc43b7cc01c4b36d6c91ff4569 /meson.build
parent1f074c3883b04bbe4d4a929b889b3c13b63af8f0 (diff)
timedatectl: add timesync-status and show-timesync commands
Closes #1589.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ef7071094..cf5db8b52 100644
--- a/meson.build
+++ b/meson.build
@@ -1405,6 +1405,13 @@ foreach term : ['utmp',
m4_defines += have ? ['-D' + name] : []
endforeach
+if get_option('timedated') or get_option('timesyncd')
+ conf.set10('ENABLE_TIMEDATECTL', true)
+ m4_defines += ['-DENABLE_TIMEDATECTL']
+else
+ conf.set10('ENABLE_TIMEDATECTL', false)
+endif
+
want_tests = get_option('tests')
install_tests = get_option('install-tests')
slow_tests = get_option('slow-tests')
@@ -2131,12 +2138,15 @@ endif
# install_rpath : rootlibexecdir,
# install : true,
# install_dir : rootlibexecdir)
+# endif
#
+# if conf.get('ENABLE_TIMEDATECTL') == 1
# exe = executable('timedatectl',
# 'src/timedate/timedatectl.c',
# include_directories : includes,
# install_rpath : rootlibexecdir,
# link_with : [libshared],
+# dependencies : [libm],
# install : true)
# public_programs += [exe]
# endif