summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-28 10:37:11 +0200
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commit374e03131279877934c5a919dcee4b8aae11cc16 (patch)
treedb4a7a2de4dd2a77d778b0c8463ccb74bbfcf58d /meson.build
parentc5051c2fdb95adf81d25af05eb4a8851f041b5f5 (diff)
meson: use a convenience static library for nspawn core
This makes it easier to link the nspawn implementation to the tests. Right now this just means that nspawn-patch-uid.c is not compiled twice, which is nice, but results in test-patch-uid being slightly bigger, which is not nice. But in general, we should use convenience libs to compile everything just once, as far as possible. Otherwise, once we start compiling a few files here twice, and a few file there thrice, we soon end up in a state where we are doing hundreds of extra compilations. So let's do the "right" thing, even if is might not be more efficient.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index c8eff6dce..6691ca7fb 100644
--- a/meson.build
+++ b/meson.build
@@ -1429,6 +1429,7 @@ includes = include_directories('src/basic',
'src/systemd',
#if 0 /// UNNEEDED by elogind
# 'src/journal',
+# 'src/nspawn',
# 'src/resolve',
# 'src/timesync',
#endif // 0
@@ -1922,6 +1923,7 @@ executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
+executable('elogind-user-runtime-dir',
user_runtime_dir_sources,
include_directories : includes,
link_with : [libshared, liblogind_core],
@@ -2746,12 +2748,10 @@ executable('elogind-cgroups-agent',
# 'src/core/mount-setup.h',
# 'src/core/loopback-setup.c',
# 'src/core/loopback-setup.h',
-# include_directories : [includes, include_directories('src/nspawn')],
-# link_with : [libshared],
-# dependencies : [libacl,
-# libblkid,
-# libseccomp,
-# libselinux],
+# include_directories : includes,
+# link_with : [libnspawn_core,
+# libshared],
+# dependencies : [libblkid],
# install_rpath : rootlibexecdir,
# install : true)
# public_programs += [exe]