summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2018-08-15 08:38:17 +0200
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commit47215898daeb235aba27ee5188798c233cff71a8 (patch)
treefe4f250c8d172dd5d463de4d0de6fee6e73e1193 /meson.build
parenta9c9852f07b1404a7b4c167ea6f5544e6cc41dab (diff)
Prep v239: Unmask Valgrind options and checks in meson files.
Doesn't hurt to leave that possibility open.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 7 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index e0276572f..cdb4dedc8 100644
--- a/meson.build
+++ b/meson.build
@@ -684,10 +684,8 @@ foreach header : ['crypt.h',
'linux/memfd.h',
'linux/vm_sockets.h',
'sys/auxv.h',
-#if 0 /// UNNEEDED by elogind
-# 'valgrind/memcheck.h',
-# 'valgrind/valgrind.h',
-#endif // 0
+ 'valgrind/memcheck.h',
+ 'valgrind/valgrind.h',
]
conf.set10('HAVE_' + header.underscorify().to_upper(),
@@ -909,9 +907,7 @@ conf.set10('ENABLE_DEBUG_MMAP_CACHE', enable_debug_mmap_cache)
conf.set10('ENABLE_DEBUG_ELOGIND', enable_debug_elogind)
#endif // 1
-#if 0 /// UNNEEDED by elogind
-# conf.set10('VALGRIND', get_option('valgrind'))
-#endif // 0
+conf.set10('VALGRIND', get_option('valgrind'))
#####################################################################
@@ -3351,10 +3347,11 @@ foreach tuple : [
# ['adm group', get_option('adm-group')],
# ['wheel group', get_option('wheel-group')],
# ['gshadow'],
-# ['valgrind', conf.get('VALGRIND') == 1],
-#else
- ['debug elogind'],
#endif // 0
+ ['valgrind', conf.get('VALGRIND') == 1],
+#if 1 /// Extra debugging for elogind
+ ['debug elogind'],
+#endif // 1
['debug hashmap'],
['debug mmap cache'],
]