summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Willing <chris.willing@linux.com>2018-09-25 08:39:53 +1000
committerSven Eden <yamakuzure@gmx.net>2018-09-25 16:32:58 +0200
commit612bbecd2f2904be8ecb84f03a5bad3fff05a467 (patch)
tree80a1e273a052bbff9f315ca90fcb1c85dad01e3b /meson.build
parent0af8158f8d08aab023d6a848a993af19be5d8480 (diff)
Deal with glibc-2.28
Closes: https://github.com/elogind/elogind/issues/74 Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Sven Eden <sven.eden@prydeworx.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3e97f57f3..0d096d847 100644
--- a/meson.build
+++ b/meson.build
@@ -509,6 +509,13 @@ foreach decl : ['char16_t',
conf.set10('HAVE_' + decl.underscorify().to_upper(), have)
endforeach
+conf.set10('HAVE_STRUCT_STATX_IN_SYS_STAT_H', cc.sizeof('struct statx', prefix : '''
+#include <sys/stat.h>
+''', args : '-D_GNU_SOURCE') > 0)
+conf.set10('HAVE_STRUCT_STATX_IN_LINUX_STAT_H', cc.sizeof('struct statx', prefix : '''
+#include <linux/stat.h>
+''', args : '-D_GNU_SOURCE') > 0)
+
foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
['IN6_ADDR_GEN_MODE_STABLE_PRIVACY', 'linux/if_link.h'],
['IFLA_VRF_TABLE', 'linux/if_link.h'],