summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-02-26 21:20:00 +0100
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:59:05 +0200
commit65c2929bed8254e5ea24bb2d3d5a403a36daf69e (patch)
treefe14db1491ac3f3af433278ea0b93fa54391d12d /meson.build
parentd6ac074bf95f61aeaa9b81db414cc3089fa22f7a (diff)
tree-wide: use reallocarray instead of our home-grown realloc_multiply (#8279)
There isn't much difference, but in general we prefer to use the standard functions. glibc provides reallocarray since version 2.26. I moved explicit_bzero is configure test to the bottom, so that the two stdlib functions are at the bottom.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f2128b9d0..e2d9b2cf6 100644
--- a/meson.build
+++ b/meson.build
@@ -585,10 +585,11 @@ foreach ident : [
#include <unistd.h>'''],
['bpf', '''#include <sys/syscall.h>
#include <unistd.h>'''],
- ['explicit_bzero' , '''#include <string.h>'''],
['statx', '''#include <sys/types.h>
#include <sys/stat.h>
// #include <unistd.h>'''],
+ ['explicit_bzero' , '''#include <string.h>'''],
+ ['reallocarray', '''#include <malloc.h>'''],
]
have = cc.has_function(ident[0], prefix : ident[1], args : '-D_GNU_SOURCE')