summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-02-28 10:20:48 +0100
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:59:08 +0200
commit89e3fcd3115e66914561b804009a3b60c574d3c9 (patch)
tree1a61066752d7abd08d1bf4ab4235841a1c7027f5 /meson.build
parentfcd0e2bc194112f772ba10bb3182da7139f1da10 (diff)
meson: install compat symlinks for systemctl and systemd (#8300)
v2: - init is a symlink to systemd, not systemctl!
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 12 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 193cbe51b..37b35c034 100644
--- a/meson.build
+++ b/meson.build
@@ -76,7 +76,7 @@ conf.set10('HAVE_SPLIT_USR', split_usr)
rootprefixdir = get_option('rootprefix')
# Unusual rootprefixdir values are used by some distros
# (see https://github.com/systemd/systemd/pull/7461).
-rootprefix_default = get_option('split-usr') ? '/' : '/usr'
+rootprefix_default = split_usr ? '/' : '/usr'
if rootprefixdir == ''
rootprefixdir = rootprefix_default
endif
@@ -105,6 +105,7 @@ datadir = join_paths(prefixdir, get_option('datadir'))
localstatedir = join_paths('/', get_option('localstatedir'))
rootbindir = join_paths(rootprefixdir, 'bin')
+rootsbindir = join_paths(rootprefixdir, 'sbin')
#if 0 /// elogind has a different default
# rootlibexecdir = join_paths(rootprefixdir, 'lib/systemd')
#else
@@ -1663,6 +1664,10 @@ test_dlopen = executable(
# install : true,
# install_dir : rootlibexecdir)
#
+# meson.add_install_script(meson_make_symlink,
+# join_paths(rootlibexecdir, 'systemd'),
+# join_paths(rootsbindir, 'init'))
+#
# exe = executable('systemd-analyze',
# systemd_analyze_sources,
# include_directories : includes,
@@ -1979,6 +1984,12 @@ endif
# install_dir : rootbindir)
# public_programs += [exe]
#
+# foreach alias : ['halt', 'poweroff', 'reboot', 'runlevel', 'shutdown', 'telinit']
+# meson.add_install_script(meson_make_symlink,
+# join_paths(rootbindir, 'systemctl'),
+# join_paths(rootsbindir, alias))
+# endforeach
+#
# if conf.get('ENABLE_BACKLIGHT') == 1
# executable('systemd-backlight',
# 'src/backlight/backlight.c',