summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-04-19 03:24:23 +0900
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commit12f73b1d85c0fe2a90680a2987641a9579662646 (patch)
treed62b0363d69c6440b1f95a4b31386846c72f3e9a /meson.build
parent5a86caf19e625fce150d5c4330783c8d5732b27f (diff)
resolvectl: rename systemd-resolve to resolvectl
For the compatibility, `systemd-resolve` will be created as a symbolic link to `resolvectl`.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index c651babe7..c7d6b5af7 100644
--- a/meson.build
+++ b/meson.build
@@ -1804,8 +1804,8 @@ test_dlopen = executable(
# install : true,
# install_dir : rootlibexecdir)
#
-# exe = executable('systemd-resolve',
-# systemd_resolve_sources,
+# exe = executable('resolvectl',
+# resolvectl_sources,
# include_directories : includes,
# link_with : [libshared,
# libbasic_gcrypt,
@@ -1819,8 +1819,12 @@ test_dlopen = executable(
# public_programs += [exe]
#
# meson.add_install_script(meson_make_symlink,
-# join_paths(bindir, 'systemd-resolve'),
+# join_paths(bindir, 'resolvectl'),
# join_paths(rootsbindir, 'resolvconf'))
+#
+# meson.add_install_script(meson_make_symlink,
+# join_paths(bindir, 'resolvectl'),
+# join_paths(bindir, 'systemd-resolve'))
# endif
#
# if conf.get('ENABLE_LOGIND') == 1