summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2018-10-24 07:43:37 +0200
committerSven Eden <sven.eden@prydeworx.com>2018-11-08 08:02:57 +0100
commit3ab9309e18658e22c1322eef168871d26cd49fb3 (patch)
tree0bc4b954e1475b00ee962c46779fda824bb9488d /meson.build
parent00b618db56b496823d74a0cc61537138ad6cb367 (diff)
Prep v240 : Add busctl to be shipped with elogind.
(emersion): > sd-bus is shipped with elogind, so it makes sense to ship the > busctl command, too. This is not only a nice helper tool to take a closer look at what is happening on the dbus, it will also prove to be usefull if something like issue #59 happens ever again. There we had to use dbus-send directly to dissect the bus traffic. Bug: #86 Closes: #86 Signed-off-by: Sven Eden <sven.eden@prydeworx.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 13 insertions, 11 deletions
diff --git a/meson.build b/meson.build
index a0d866657..c5c35dfe6 100644
--- a/meson.build
+++ b/meson.build
@@ -2690,17 +2690,19 @@ executable('elogind-cgroups-agent',
# install_rpath : rootlibexecdir,
# install : true)
# public_programs += [exe]
-#
-# exe = executable('busctl',
-# 'src/busctl/busctl.c',
-# 'src/busctl/busctl-introspect.c',
-# 'src/busctl/busctl-introspect.h',
-# include_directories : includes,
-# link_with : [libshared],
-# install_rpath : rootlibexecdir,
-# install : true)
-# public_programs += [exe]
-#
+#endif // 0
+
+exe = executable('busctl',
+ 'src/busctl/busctl.c',
+ 'src/busctl/busctl-introspect.c',
+ 'src/busctl/busctl-introspect.h',
+ include_directories : includes,
+ link_with : [libshared],
+ install_rpath : rootlibexecdir,
+ install : true)
+public_programs += [exe]
+
+#if 0 /// UNNEEDED by elogind
# if conf.get('ENABLE_SYSUSERS') == 1
# exe = executable('systemd-sysusers',
# 'src/sysusers/sysusers.c',