summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-10-03 10:32:34 +0200
committerSven Eden <yamakuzure@gmx.net>2017-11-22 08:26:56 +0100
commit516c369291c7b5b606c5406c1e02e6e3933b5e61 (patch)
tree847db61605d998344da6d8f13abbec2852848200 /meson.build
parent0b49a6ad440392bc8758db5dfd522287c80ee6a8 (diff)
build-sys: change all HAVE_DECL_ macros to HAVE_
This is a legacy of autotools, where one detection routine used a different prefix then the others. $ git grep -e HAVE_DECL_ -l|xargs sed -i s/HAVE_DECL_/HAVE_/g
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 9 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index ecc72c0fe..7e0890404 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project('elogind', 'c',
- version : '234',
+ version : '235',
license : 'LGPLv2+',
default_options: [
'c_std=gnu99',
@@ -10,6 +10,9 @@ project('elogind', 'c',
meson_version : '>= 0.40',
)
+libsystemd_version = '0.19.0'
+libudev_version = '1.6.6'
+
# We need the same data in three different formats, ugh!
# Also, for hysterical reasons, we use different variable
# names, sometimes. Not all variables are included in every
@@ -469,7 +472,7 @@ foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
]
prefix = decl.length() > 2 ? decl[2] : ''
have = cc.has_header_symbol(decl[1], decl[0], prefix : prefix)
- conf.set10('HAVE_DECL_' + decl[0], have)
+ conf.set10('HAVE_' + decl[0], have)
endforeach
skip = false
@@ -502,15 +505,15 @@ foreach ident : [
]
have = cc.has_function(ident[0], prefix : ident[1])
- conf.set10('HAVE_DECL_' + ident[0].to_upper(), have)
+ conf.set10('HAVE_' + ident[0].to_upper(), have)
endforeach
if cc.has_function('getrandom', prefix : '''#include <sys/random.h>''')
conf.set('USE_SYS_RANDOM_H', true)
- conf.set10('HAVE_DECL_GETRANDOM', true)
+ conf.set10('HAVE_GETRANDOM', true)
else
have = cc.has_function('getrandom', prefix : '''#include <linux/random.h>''')
- conf.set10('HAVE_DECL_GETRANDOM', have)
+ conf.set10('HAVE_GETRANDOM', have)
endif
#####################################################################
@@ -1289,7 +1292,7 @@ subdir('src/login')
# 'systemd',
# libsystemd_internal_sources,
# journal_internal_sources,
-# version : '0.19.0',
+# version : libsystemd_version,
# include_directories : includes,
# link_args : ['-shared',
# '-Wl,--version-script=' + libsystemd_sym_path],