summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2018-09-26 17:58:00 +0200
committerSven Eden <yamakuzure@gmx.net>2018-09-26 17:58:00 +0200
commit938f002d22d44380b2087a43ef1666cb762434cd (patch)
tree8b6d469ddaee57d03bbab84188ebb2e3b9cf416d /meson.build
parente49878a10009b0278121aa0d8a53cb47d73f5145 (diff)
Enhance the dealing with glibc-2.28
It appears that the necessary bits were already there, but commented out. When meson checked for 'struct statx', the inclusion of both sys/stat.h and linux/stat.h where commented out. Uncommenting them should be enough.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 2 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 8b62c789e..45262dcff 100644
--- a/meson.build
+++ b/meson.build
@@ -491,8 +491,8 @@ decl_headers = '''
#include <uchar.h>
#include <linux/ethtool.h>
#include <linux/fib_rules.h>
-//#include <linux/stat.h>
-//#include <sys/stat.h>
+#include <linux/stat.h>
+#include <sys/stat.h>
'''
# FIXME: key_serial_t is only defined in keyutils.h, this is bound to fail
@@ -509,13 +509,6 @@ foreach decl : ['char16_t',
conf.set10('HAVE_' + decl.underscorify().to_upper(), have)
endforeach
-conf.set10('HAVE_STRUCT_STATX_IN_SYS_STAT_H', cc.sizeof('struct statx', prefix : '''
-#include <sys/stat.h>
-''', args : '-D_GNU_SOURCE') > 0)
-conf.set10('HAVE_STRUCT_STATX_IN_LINUX_STAT_H', cc.sizeof('struct statx', prefix : '''
-#include <linux/stat.h>
-''', args : '-D_GNU_SOURCE') > 0)
-
foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
['IN6_ADDR_GEN_MODE_STABLE_PRIVACY', 'linux/if_link.h'],
['IFLA_VRF_TABLE', 'linux/if_link.h'],