summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-06-11 13:17:43 +0200
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commita6c19e8cc6f4e48f564a9a4d45872b11cd49374b (patch)
tree0cb6d9113d6ce47e23b22837979220f55aa20735 /meson.build
parentc1fc133d248627108edd28f86d4ed345d08b5349 (diff)
meson: also reject shifts that change the sign bit
../src/test/test-sizeof.c: In function ‘main’: ../src/test/test-sizeof.c:70:24: error: result of ‘1 << 31’ requires 33 bits to represent, but ‘int’ only has 32 bits [-Werror=shift-overflow=] X = (1 << 31), ^~ cc1: some warnings being treated as errors Follow-up for b05ecb8cadd8c32d31b1aabcff4e507bd89b5465.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index fe014eda7..df1dc4fca 100644
--- a/meson.build
+++ b/meson.build
@@ -387,6 +387,7 @@ endif
# '-Wwrite-strings',
# '-Werror=overflow',
# '-Werror=shift-count-overflow',
+# '-Werror=shift-overflow=2',
# '-Wdate-time',
# '-Wnested-externs',
# '-ffast-math',
@@ -1930,6 +1931,7 @@ executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
executable('elogind-user-runtime-dir',
+executable('elogind-user-runtime-dir',
user_runtime_dir_sources,
include_directories : includes,
link_with : [libshared, liblogind_core],