summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-06-25 22:40:40 +0900
committerSven Eden <sven.eden@prydeworx.com>2018-10-29 10:18:40 +0100
commitb208849e9f4a903e3e90597b6115abc8505ed1fb (patch)
tree00b79d58f7aaeddc81da59efd3d28963a5208794 /meson.build
parente266d211eea9280e70e89d24051bdec75d6c4095 (diff)
meson: check whether gnutls supports TCP fast open
Fixes #9403 (cherry picked from commit f02582f69fe1e7663a87ba80bd4f90d5d23ee75f)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 38312a56f..d3f84990d 100644
--- a/meson.build
+++ b/meson.build
@@ -1342,7 +1342,7 @@ conf.set10('HAVE_DBUS', have)
#
# dns_over_tls = get_option('dns-over-tls')
# if dns_over_tls != 'false'
-# have = conf.get('HAVE_GNUTLS') == 1
+# have = libgnutls != [] and libgnutls.version().version_compare('>=3.5.3')
# if dns_over_tls == 'true' and not have
# error('DNS-over-TLS support was requested, but dependencies are not available')
# endif
@@ -2002,6 +2002,7 @@ exe = executable('elogind-inhibit',
install_dir : rootbindir)
public_programs += [exe]
executable('elogind-user-runtime-dir',
+ executable('elogind-user-runtime-dir',
user_runtime_dir_sources,
include_directories : includes,
link_with : [libshared],