summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-08-19 19:11:30 +0200
committerSven Eden <sven.eden@prydeworx.com>2018-10-29 10:18:22 +0100
commited82488a18a0b0eeae112cd6aec178622a1579cd (patch)
tree89d4bddcf250313207a05b1220566c5fe4b60b76 /meson.build
parentf554f9be86351faa0e19f070ee74ff9190beb669 (diff)
meson: rename -Ddebug to -Ddebug-extra
Meson added -Doptimization and -Ddebug options, which obviously causes a conflict with our -Ddebug options. Let's rename it. Fixes #9883. (cherry picked from commit 8f6b442a78d0b485f044742ad90b2e8271b4e68e)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c73b29e88..ed32e5bd9 100644
--- a/meson.build
+++ b/meson.build
@@ -922,7 +922,7 @@ enable_debug_mmap_cache = false
#if 1 /// additional elogind debug mode
enable_debug_elogind = false
#endif // 1
-foreach name : get_option('debug')
+foreach name : get_option('debug-extra')
if name == 'hashmap'
enable_debug_hashmap = true
elif name == 'mmap-cache'