summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-05-02 17:05:51 +0900
committerSven Eden <yamakuzure@gmx.net>2018-06-28 09:24:07 +0200
commitf3a488f8e59dee114d4dc975c45b78d3da1fd9c6 (patch)
tree3f32a7a2893e15e5ddb0baec4b52db32ee48d394 /meson.build
parent34d5313740180b0455f0e43bcff401fb6bbd258f (diff)
meson: drop 'name' argument in cc.has_argument() (#8878)
(cherry picked from commit b0903bb585d2158f78a4cf603fde4aed5474e2b9)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index aa1234a14..3145ee9de 100644
--- a/meson.build
+++ b/meson.build
@@ -498,8 +498,7 @@ endforeach
if get_option('buildtype') != 'debug'
foreach arg : ['-ffunction-sections',
'-fdata-sections']
- if cc.has_argument(arg,
- name : '@0@ is supported'.format(arg))
+ if cc.has_argument(arg)
add_project_arguments(arg, language : 'c')
endif
endforeach