summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorMike Gilbert <floppymaster@gmail.com>2018-01-04 07:14:20 -0500
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:49:49 +0200
commit58a14cca587139fc8992631844e7e062b9c77386 (patch)
tree1a12c115f0d6760d2a8f436cf83160bb432e4e58 /meson_options.txt
parente3be95f4c8e19c644a6da25d3f0a085905a2fa6f (diff)
meson: don't search PATH for telinit (#7770)
On a typical system running systemd, the telinit in PATH is very likely to be a symlink to systemctl. Setting TELINIT to this may result in an infinite recursion if telinit is called and sd_booted() == 0. This may commonly occur in a chroot environment. Bug: https://bugs.gentoo.org/642724 [zj: The path was originally hardcoded as "/lib/upstart/telinit", but was made configurable without changing the default in 4ad61fd1806dde23d2c99043b4bed91a196d2c82. Then the default was changed to `/lib/sysvinit/telinit` in abaaabf40a9891014ed4c402d7beb5a67ac256b1. Then it started being autodetected when meson support was added in 5c23128daba7236a6080383b2a5649033cfef85c. This patch restores the behaviour that was implemented in configure.ac at the time of its removal.]
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 4e2f472d6..aba8d1c20 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -30,7 +30,8 @@ option('rootprefix', type : 'string',
# description : 'the directory where the SysV init scripts are located')
# option('sysvrcnd-path', type : 'string', value : '/etc/rc.d',
# description : 'the base directory for SysV rcN.d directories')
-# option('telinit-path', type : 'string', description : 'path to telinit')
+# option('telinit-path', type : 'string', value : '/lib/sysvinit/telinit',
+# description : 'path to telinit')
# option('rc-local', type : 'string',
# value : '/etc/rc.local')
# option('halt-local', type : 'string',