summaryrefslogtreecommitdiff
path: root/rules
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-08-14 01:57:02 +0200
committerLennart Poettering <lennart@poettering.net>2013-08-14 01:57:02 +0200
commit3731acf1acfb4a6eb68374a5b137f3b368f63381 (patch)
treea6b378b127df46126ee8e334fc895bff10451b82 /rules
parent405e0255d5e6950180d9563f1a26294b5360db03 (diff)
backlight: add minimal tool to save/restore screen brightness across reboots
As many laptops don't save/restore screen brightness across reboots, let's do this in systemd with a minimal tool, that restores the brightness as early as possible, and saves it as late as possible. This will cover consoles and graphical logins, but graphical desktops should do their own per-user stuff probably. This only touches firmware brightness controls for now.
Diffstat (limited to 'rules')
-rw-r--r--rules/99-systemd.rules.in4
l---------rules/Makefile1
2 files changed, 5 insertions, 0 deletions
diff --git a/rules/99-systemd.rules.in b/rules/99-systemd.rules.in
index e9b2da7b3..ac4bc86c8 100644
--- a/rules/99-systemd.rules.in
+++ b/rules/99-systemd.rules.in
@@ -51,6 +51,10 @@ SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}=="*:0701??:
ACTION=="add", SUBSYSTEM=="net", KERNEL!="lo", RUN+="@rootlibexecdir@/systemd-sysctl --prefix=/proc/sys/net/ipv4/conf/$name --prefix=/proc/sys/net/ipv4/neigh/$name --prefix=/proc/sys/net/ipv6/conf/$name --prefix=/proc/sys/net/ipv6/neigh/$name"
+# Pull in backlight save/restore for all firmware backlight devices
+
+ACTION=="add", SUBSYSTEM=="backlight", ATTR{type}=="firmware", TAG+="systemd", ENV{SYSTEMD_WANTS}+="systemd-backlight@sys%p.service"
+
# Asynchronously mount file systems implemented by these modules as
# soon as they are loaded.
diff --git a/rules/Makefile b/rules/Makefile
new file mode 120000
index 000000000..bd1047548
--- /dev/null
+++ b/rules/Makefile
@@ -0,0 +1 @@
+../src/Makefile \ No newline at end of file