summaryrefslogtreecommitdiff
path: root/shell-completion/bash
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-07-31 08:28:21 +0200
committerSven Eden <yamakuzure@gmx.net>2017-08-04 14:34:53 +0200
commitf3dca9e3c3373a5817582d4b583077b8f9358604 (patch)
treeea76ef30c91cf194ec7b47f59df44d452f26e10b /shell-completion/bash
parentf3061b4c6efa8275466c56f291eca43d36178213 (diff)
General: Update build system to upstream support of meson+ninja.
Upstream thinks, that the auto tools are too 'legacy', or that they are at least no longer fitting. We follow, as the classic auto tools files have been removed, so no other choice here...
Diffstat (limited to 'shell-completion/bash')
l---------shell-completion/bash/Makefile1
-rw-r--r--shell-completion/bash/meson.build54
2 files changed, 54 insertions, 1 deletions
diff --git a/shell-completion/bash/Makefile b/shell-completion/bash/Makefile
deleted file mode 120000
index d0b0e8e00..000000000
--- a/shell-completion/bash/Makefile
+++ /dev/null
@@ -1 +0,0 @@
-../Makefile \ No newline at end of file
diff --git a/shell-completion/bash/meson.build b/shell-completion/bash/meson.build
new file mode 100644
index 000000000..684d1b5c2
--- /dev/null
+++ b/shell-completion/bash/meson.build
@@ -0,0 +1,54 @@
+bashcompletiondir = get_option('bashcompletiondir')
+if bashcompletiondir == ''
+ bash_completion = dependency('bash-completion', required : false)
+ if bash_completion.found()
+ bashcompletiondir = bash_completion.get_pkgconfig_variable('completionsdir')
+ else
+ bashcompletiondir = join_paths(datadir, 'bash-completion/completions')
+ endif
+
+ message('bash completions: @0@'.format(bashcompletiondir))
+endif
+
+if bashcompletiondir != 'no'
+#if 0 /// elogind has a *very* short list for this...
+# bash_systemctl = configure_file(
+# input : 'systemctl.in',
+# output : 'systemctl',
+# configuration : substs)
+#
+# items = [['busctl', ''],
+# ['journalctl', ''],
+# ['systemd-analyze', ''],
+# ['systemd-cat', ''],
+# ['systemd-cgls', ''],
+# ['systemd-cgtop', ''],
+# ['systemd-delta', ''],
+# ['systemd-detect-virt', ''],
+# ['systemd-nspawn', ''],
+# ['systemd-path', ''],
+# ['systemd-run', ''],
+# ['udevadm', ''],
+# ['kernel-install', ''],
+# [bash_systemctl, ''],
+# ['bootctl', 'ENABLE_EFI'],
+# ['coredumpctl', 'ENABLE_COREDUMP'],
+# ['hostnamectl', 'ENABLE_HOSTNAMED'],
+# ['localectl', 'ENABLE_LOCALED'],
+# ['loginctl', 'ENABLE_LOGIND'],
+# ['machinectl', 'ENABLE_MACHINED'],
+# ['networkctl', 'ENABLE_NETWORKD'],
+# ['systemd-resolve', 'ENABLE_RESOLVED'],
+# ['timedatectl', 'ENABLE_TIMEDATED'],
+#else
+ items = [['loginctl', ''],
+#endif // 0
+ ]
+
+ foreach item : items
+ if item[1] == '' or conf.get(item[1], false)
+ install_data(item[0],
+ install_dir : bashcompletiondir)
+ endif
+ endforeach
+endif