summaryrefslogtreecommitdiff
path: root/shell-completion
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-10-03 10:41:51 +0200
committerSven Eden <yamakuzure@gmx.net>2017-11-23 08:11:42 +0100
commit3344b839df8fe2dd2b4a4f470225e4c407cf2faa (patch)
treea64c86cfe6adc5718143f5604fef893cfd94a865 /shell-completion
parent7d729de3a70bc7a7fef69f5cea03fcbf835e118a (diff)
build-sys: use #if Y instead of #ifdef Y everywhere
The advantage is that is the name is mispellt, cpp will warn us. $ git grep -Ee "conf.set\('(HAVE|ENABLE)_" -l|xargs sed -r -i "s/conf.set\('(HAVE|ENABLE)_/conf.set10('\1_/" $ git grep -Ee '#ifn?def (HAVE|ENABLE)' -l|xargs sed -r -i 's/#ifdef (HAVE|ENABLE)/#if \1/; s/#ifndef (HAVE|ENABLE)/#if ! \1/;' $ git grep -Ee 'if.*defined\(HAVE' -l|xargs sed -i -r 's/defined\((HAVE_[A-Z0-9_]*)\)/\1/g' $ git grep -Ee 'if.*defined\(ENABLE' -l|xargs sed -i -r 's/defined\((ENABLE_[A-Z0-9_]*)\)/\1/g' + manual changes to meson.build squash! build-sys: use #if Y instead of #ifdef Y everywhere v2: - fix incorrect setting of HAVE_LIBIDN2
Diffstat (limited to 'shell-completion')
-rw-r--r--shell-completion/bash/meson.build2
-rw-r--r--shell-completion/zsh/meson.build2
2 files changed, 2 insertions, 2 deletions
diff --git a/shell-completion/bash/meson.build b/shell-completion/bash/meson.build
index 684d1b5c2..de467101a 100644
--- a/shell-completion/bash/meson.build
+++ b/shell-completion/bash/meson.build
@@ -46,7 +46,7 @@ if bashcompletiondir != 'no'
]
foreach item : items
- if item[1] == '' or conf.get(item[1], false)
+ if item[1] == '' or conf.get(item[1]) == 1
install_data(item[0],
install_dir : bashcompletiondir)
endif
diff --git a/shell-completion/zsh/meson.build b/shell-completion/zsh/meson.build
index 4ddafe2a6..be30ebf0e 100644
--- a/shell-completion/zsh/meson.build
+++ b/shell-completion/zsh/meson.build
@@ -43,7 +43,7 @@ if zshcompletiondir != 'no'
]
foreach item : items
- if item[1] == '' or conf.get(item[1], false)
+ if item[1] == '' or conf.get(item[1]) == 1
install_data(item[0],
install_dir : zshcompletiondir)
endif