summaryrefslogtreecommitdiff
path: root/src/basic/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-02-21 17:42:59 +0100
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:59:02 +0200
commit608b07b67bf9f097cec658e15d0adbff5f18985b (patch)
tree233f367284f7c41c37bb2f2a2489d096c2582793 /src/basic/meson.build
parent8053a2643f85274e7f4a3ca2bf1f450756a288f2 (diff)
basic: add a common syscall wrapper around reboot()
This mimics the raw_clone() call we have in place already and establishes a new syscall wrapper raw_reboot() that wraps the kernel's reboot() system call in a bit more low-level fashion that glibc's reboot() wrapper. The main difference is that the extra "arg" argument is supported. Ultimately this just replaces the syscall wrapper implementation we currently have at three places in our codebase by a single one. With this change this means that all our syscall() invocations are neatly separated out in static inline system call wrappers in our header functions.
Diffstat (limited to 'src/basic/meson.build')
-rw-r--r--src/basic/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/basic/meson.build b/src/basic/meson.build
index 360c5db0b..cf0038b83 100644
--- a/src/basic/meson.build
+++ b/src/basic/meson.build
@@ -158,6 +158,7 @@
# ratelimit.c
# ratelimit.h
# raw-clone.h
+# raw-reboot.h
# refcnt.h
# replace-var.c
# replace-var.h