summaryrefslogtreecommitdiff
path: root/src/basic/meson.build
diff options
context:
space:
mode:
authorDaniel Mack <daniel@zonque.org>2016-10-18 17:57:10 +0200
committerSven Eden <yamakuzure@gmx.net>2017-11-20 17:28:50 +0100
commitb605cf820c4831451fd009825a914d6f98045219 (patch)
tree6320971d755d18f28b3387d9de29ea28052d57a8 /src/basic/meson.build
parent294d3039be600ee7fbe43222fcf7084c99e63b94 (diff)
Add abstraction model for BPF programs
This object takes a number of bpf_insn members and wraps them together with the in-kernel reference id. Will be needed by the firewall code.
Diffstat (limited to 'src/basic/meson.build')
-rw-r--r--src/basic/meson.build20
1 files changed, 11 insertions, 9 deletions
diff --git a/src/basic/meson.build b/src/basic/meson.build
index 10acb9aef..51e5b1b16 100644
--- a/src/basic/meson.build
+++ b/src/basic/meson.build
@@ -1,5 +1,7 @@
#if 0 /// elogind has a shorter list
# basic_sources_plain = files('''
+# MurmurHash2.c
+# MurmurHash2.h
# af-list.c
# af-list.h
# alloc-util.c
@@ -17,6 +19,8 @@
# bitmap.c
# bitmap.h
# blkid-util.h
+# bpf-program.c
+# bpf-program.h
# btrfs-ctree.h
# btrfs-util.c
# btrfs-util.h
@@ -25,10 +29,10 @@
# bus-label.h
# calendarspec.c
# calendarspec.h
-# capability-util.c
-# capability-util.h
# cap-list.c
# cap-list.h
+# capability-util.c
+# capability-util.h
# cgroup-util.c
# cgroup-util.h
# chattr-util.c
@@ -62,10 +66,10 @@
# extract-word.h
# fd-util.c
# fd-util.h
-# fileio.c
-# fileio.h
# fileio-label.c
# fileio-label.h
+# fileio.c
+# fileio.h
# format-util.h
# fs-util.c
# fs-util.h
@@ -83,9 +87,9 @@
# hostname-util.h
# in-addr-util.c
# in-addr-util.h
-# ioprio.h
# io-util.c
# io-util.h
+# ioprio.h
# journal-importer.c
# journal-importer.h
# khash.c
@@ -107,13 +111,11 @@
# mempool.c
# mempool.h
# missing_syscall.h
+# mkdir-label.c
# mkdir.c
# mkdir.h
-# mkdir-label.c
# mount-util.c
# mount-util.h
-# MurmurHash2.c
-# MurmurHash2.h
# nss-util.h
# ordered-set.c
# ordered-set.h
@@ -139,9 +141,9 @@
# rlimit-util.h
# rm-rf.c
# rm-rf.h
-# securebits.h
# securebits-util.c
# securebits-util.h
+# securebits.h
# selinux-util.c
# selinux-util.h
# set.h