summaryrefslogtreecommitdiff
path: root/src/core/meson.build
diff options
context:
space:
mode:
authorDaniel Mack <daniel@zonque.org>2016-11-03 17:30:06 +0100
committerSven Eden <yamakuzure@gmx.net>2017-11-21 07:02:10 +0100
commit7c8473b165e5a0af8a85fc9b40bb9eb319e7554a (patch)
tree7f6ea518691c10b7513e4430a848df0230deb737 /src/core/meson.build
parentb605cf820c4831451fd009825a914d6f98045219 (diff)
Add IP address address ACL representation and parser
Add a config directive parser that takes multiple space separated IPv4 or IPv6 addresses with optional netmasks in CIDR notation rvalue and puts a parsed version of it to linked list of IPAddressAccessItem objects. The code actually using this will be added later.
Diffstat (limited to 'src/core/meson.build')
-rw-r--r--src/core/meson.build176
1 files changed, 89 insertions, 87 deletions
diff --git a/src/core/meson.build b/src/core/meson.build
index a9d4c3d73..2790e431f 100644
--- a/src/core/meson.build
+++ b/src/core/meson.build
@@ -1,115 +1,117 @@
#if 0 /// elogind has only two of the parts here in it...
# libcore_la_sources = '''
-# unit.c
-# unit.h
-# unit-printf.c
-# unit-printf.h
-# job.c
-# job.h
-# manager.c
-# manager.h
-# transaction.c
-# transaction.h
-# load-fragment.c
-# load-fragment.h
-# service.c
-# service.h
-# socket.c
-# socket.h
-# target.c
-# target.h
-# device.c
-# device.h
-# mount.c
-# mount.h
+# audit-fd.c
+# audit-fd.h
# automount.c
# automount.h
-# swap.c
-# swap.h
-# timer.c
-# timer.h
-# path.c
-# path.h
-# slice.c
-# slice.h
-# scope.c
-# scope.h
-# load-dropin.c
-# load-dropin.h
-# execute.c
-# execute.h
-# dynamic-user.c
-# dynamic-user.h
-# kill.c
-# kill.h
-# dbus.c
-# dbus.h
-# dbus-manager.c
-# dbus-manager.h
-# dbus-unit.c
-# dbus-unit.h
+# cgroup.c
+# cgroup.h
+# dbus-automount.c
+# dbus-automount.h
+# dbus-cgroup.c
+# dbus-cgroup.h
+# dbus-device.c
+# dbus-device.h
+# dbus-execute.c
+# dbus-execute.h
# dbus-job.c
# dbus-job.h
+# dbus-kill.c
+# dbus-kill.h
+# dbus-manager.c
+# dbus-manager.h
+# dbus-mount.c
+# dbus-mount.h
+# dbus-path.c
+# dbus-path.h
+# dbus-scope.c
+# dbus-scope.h
# dbus-service.c
# dbus-service.h
+# dbus-slice.c
+# dbus-slice.h
# dbus-socket.c
# dbus-socket.h
-# dbus-target.c
-# dbus-target.h
-# dbus-device.c
-# dbus-device.h
-# dbus-mount.c
-# dbus-mount.h
-# dbus-automount.c
-# dbus-automount.h
# dbus-swap.c
# dbus-swap.h
+# dbus-target.c
+# dbus-target.h
# dbus-timer.c
# dbus-timer.h
-# dbus-path.c
-# dbus-path.h
-# dbus-slice.c
-# dbus-slice.h
-# dbus-scope.c
-# dbus-scope.h
-# dbus-execute.c
-# dbus-execute.h
-# dbus-kill.c
-# dbus-kill.h
-# dbus-cgroup.c
-# dbus-cgroup.h
-# cgroup.c
-# cgroup.h
-# selinux-access.c
-# selinux-access.h
-# selinux-setup.c
-# selinux-setup.h
-# smack-setup.c
-# smack-setup.h
+# dbus-unit.c
+# dbus-unit.h
+# dbus.c
+# dbus.h
+# device.c
+# device.h
+# dynamic-user.c
+# dynamic-user.h
+# emergency-action.c
+# emergency-action.h
+# execute.c
+# execute.h
+# hostname-setup.c
+# hostname-setup.h
# ima-setup.c
# ima-setup.h
-# locale-setup.h
+# ip-address-access.c
+# ip-address-access.h
+# job.c
+# job.h
+# kill.c
+# kill.h
+# killall.c
+# killall.h
+# kmod-setup.c
+# kmod-setup.h
+# load-dropin.c
+# load-dropin.h
+# load-fragment.c
+# load-fragment.h
# locale-setup.c
-# hostname-setup.c
-# hostname-setup.h
+# locale-setup.h
+# loopback-setup.c
+# loopback-setup.h
# machine-id-setup.c
# machine-id-setup.h
+# manager.c
+# manager.h
# mount-setup.c
# mount-setup.h
-# kmod-setup.c
-# kmod-setup.h
-# loopback-setup.h
-# loopback-setup.c
+# mount.c
+# mount.h
# namespace.c
# namespace.h
-# killall.h
-# killall.c
-# audit-fd.c
-# audit-fd.h
+# path.c
+# path.h
+# scope.c
+# scope.h
+# selinux-access.c
+# selinux-access.h
+# selinux-setup.c
+# selinux-setup.h
+# service.c
+# service.h
# show-status.c
# show-status.h
-# emergency-action.c
-# emergency-action.h
+# slice.c
+# slice.h
+# smack-setup.c
+# smack-setup.h
+# socket.c
+# socket.h
+# swap.c
+# swap.h
+# target.c
+# target.h
+# timer.c
+# timer.h
+# transaction.c
+# transaction.h
+# unit-printf.c
+# unit-printf.h
+# unit.c
+# unit.h
# '''.split()
#else
libcore_la_sources = files('''