summaryrefslogtreecommitdiff
path: root/src/core/meson.build
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2018-03-13 08:17:29 +0100
committerSven Eden <yamakuzure@gmx.net>2018-03-13 08:18:56 +0100
commitaaae10b1838c7cb84608fe905e6360b9b8544e1b (patch)
treee78259842861d6315f80afe8065639a43f9513ca /src/core/meson.build
parentb3fbcb51172f39bd89e35b408fb774547d3800ec (diff)
Prep v236: Apply missing upstream updates to the build system
Diffstat (limited to 'src/core/meson.build')
-rw-r--r--src/core/meson.build33
1 files changed, 20 insertions, 13 deletions
diff --git a/src/core/meson.build b/src/core/meson.build
index 8da7c391a..ce8c0f647 100644
--- a/src/core/meson.build
+++ b/src/core/meson.build
@@ -1,3 +1,20 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# elogind is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# elogind is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with elogind; If not, see <http://www.gnu.org/licenses/>.
+
#if 0 /// elogind has only two of the parts here in it...
# libcore_la_sources = '''
# audit-fd.c
@@ -207,26 +224,16 @@ libcore_la_sources = files('''
# output : 'org.freedesktop.systemd1.policy.in',
# configuration : substs)
#
-# custom_target(
+# i18n.merge_file(
# 'org.freedesktop.systemd1.policy',
# input : policy_in,
# output : 'org.freedesktop.systemd1.policy',
-# command : intltool_command,
+# po_dir : po_dir,
+# data_dirs : po_dir,
# install : install_polkit,
# install_dir : polkitpolicydir)
#endif // 0
-# TODO: this might work with meson from git, see
-# https://github.com/mesonbuild/meson/issues/1441#issuecomment-283585493
-#
-# i18n.merge_file(
-# 'org.freedesktop.systemd1.policy',
-# po_dir : po_dir,
-# input : policy_in,
-# output : 'org.freedesktop.systemd1.policy',
-# install : install_polkit,
-# install_dir : polkitpolicydir)
-
#if 0 /// totally UNNEEDED in elogind
# install_data('system.conf',
# 'user.conf',