summaryrefslogtreecommitdiff
path: root/src/core
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-12-07 18:59:58 +0100
committerSven Eden <yamakuzure@gmx.net>2017-12-07 18:59:58 +0100
commit326e11bd6182202b830c66742c1ddd6d419e8f5f (patch)
treec0181fea9d655a5821676a8fd029cc6989d6c133 /src/core
parent3344b839df8fe2dd2b4a4f470225e4c407cf2faa (diff)
Apply updates from upstream
Diffstat (limited to 'src/core')
-rw-r--r--src/core/cgroup.c1
-rw-r--r--src/core/cgroup.h1
-rw-r--r--src/core/meson.build26
3 files changed, 15 insertions, 13 deletions
diff --git a/src/core/cgroup.c b/src/core/cgroup.c
index c0f07ca9a..6e200ccb6 100644
--- a/src/core/cgroup.c
+++ b/src/core/cgroup.c
@@ -21,6 +21,7 @@
#include <fnmatch.h>
#include "alloc-util.h"
+#include "bpf-firewall.h"
#include "cgroup-util.h"
#include "cgroup.h"
#include "fd-util.h"
diff --git a/src/core/cgroup.h b/src/core/cgroup.h
index af906db21..dc4b4cadf 100644
--- a/src/core/cgroup.h
+++ b/src/core/cgroup.h
@@ -24,6 +24,7 @@
//#include "list.h"
//#include "time-util.h"
#include "cgroup-util.h"
+#include "ip-address-access.h"
#if 0 /// UNNEEDED by elogind
typedef struct CGroupContext CGroupContext;
diff --git a/src/core/meson.build b/src/core/meson.build
index 482d1f09b..e58312d81 100644
--- a/src/core/meson.build
+++ b/src/core/meson.build
@@ -133,13 +133,13 @@ libcore_la_sources = files('''
# output: 'load-fragment-gperf.gperf',
# command : [m4, '-P'] + m4_defines + ['@INPUT@'],
# capture : true)
-#
+
# load_fragment_gperf_c = custom_target(
# 'load-fragment-gperf.c',
# input : load_fragment_gperf_gperf,
# output : 'load-fragment-gperf.c',
# command : [gperf, '@INPUT@', '--output-file', '@OUTPUT@'])
-#
+
# awkscript = 'load-fragment-gperf-nulstr.awk'
# load_fragment_gperf_nulstr_c = custom_target(
# 'load-fragment-gperf-nulstr.c',
@@ -147,7 +147,7 @@ libcore_la_sources = files('''
# output : 'load-fragment-gperf-nulstr.c',
# command : [awk, '-f', '@INPUT0@', '@INPUT1@'],
# capture : true)
-#
+
# libcore = static_library(
# 'core',
# libcore_la_sources,
@@ -162,9 +162,9 @@ libcore_la_sources = files('''
# libkmod,
# libapparmor,
# libmount])
-#
+
# systemd_sources = files('main.c')
-#
+
# systemd_shutdown_sources = files('''
# shutdown.c
# umount.c
@@ -174,15 +174,15 @@ libcore_la_sources = files('''
# killall.c
# killall.h
# '''.split())
-#
+
# in_files = [['macros.systemd', rpmmacrosdir],
# ['triggers.systemd', ''],
# ['systemd.pc', pkgconfigdatadir]]
-#
+
# foreach item : in_files
# file = item[0]
# dir = item[1]
-#
+
# # If 'no', disable generation completely.
# # If '', generate, but do not install.
# if dir != 'no'
@@ -196,17 +196,17 @@ libcore_la_sources = files('''
# endif
# endif
# endforeach
-#
+
# install_data('org.freedesktop.systemd1.conf',
# install_dir : dbuspolicydir)
# install_data('org.freedesktop.systemd1.service',
# install_dir : dbussystemservicedir)
-#
+
# policy_in = configure_file(
# input : 'org.freedesktop.systemd1.policy.in.in',
# output : 'org.freedesktop.systemd1.policy.in',
# configuration : substs)
-#
+
# custom_target(
# 'org.freedesktop.systemd1.policy',
# input : policy_in,
@@ -231,12 +231,12 @@ libcore_la_sources = files('''
# install_data('system.conf',
# 'user.conf',
# install_dir : pkgsysconfdir)
-#
+
# meson.add_install_script('sh', '-c', mkdir_p.format(systemshutdowndir))
# meson.add_install_script('sh', '-c', mkdir_p.format(systemsleepdir))
# meson.add_install_script('sh', '-c', mkdir_p.format(systemgeneratordir))
# meson.add_install_script('sh', '-c', mkdir_p.format(usergeneratordir))
-#
+
# meson.add_install_script('sh', '-c',
# mkdir_p.format(join_paths(pkgsysconfdir, 'system/multi-user.target.wants')))
# meson.add_install_script('sh', '-c',