summaryrefslogtreecommitdiff
path: root/src/core
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2018-09-28 19:39:43 +0200
committerSven Eden <yamakuzure@gmx.net>2018-09-28 19:39:43 +0200
commiteee8275c6ac591d293085ee5a4c0242242413403 (patch)
tree839de02c51beb20a1ed6a491b3c1c8788376e5ec /src/core
parentb0c24eee5154ec046725b108fdb3cded008afc00 (diff)
Prep v239: Unmask creation of systemshutdowndir and systemsleepdir.
The creation of the system shutdown dir and the system sleep dir had been masked. This was an oversight that is now fixed. systemshutdowndir defaults to [/usr]/lib/elogind/system-shutdown systemsleepdir defaults to [/usr]/lib/elogind/system-sleep Executables in these folders are meant to run prior the system either shuts down or goes to sleep, including all variants.
Diffstat (limited to 'src/core')
-rw-r--r--src/core/meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/core/meson.build b/src/core/meson.build
index 22a3c6ba5..5e7b6981d 100644
--- a/src/core/meson.build
+++ b/src/core/meson.build
@@ -130,7 +130,7 @@ libcore_la_sources = files('''
'''.split())
#endif // 0
-#if 0 /// The rest is not needed by elogind, we use the sources directly in login
+#if 0 /// Almost the rest is not needed by elogind, we use the sources directly in login
# load_fragment_gperf_gperf = custom_target(
# 'load-fragment-gperf.gperf',
# input : 'load-fragment-gperf.gperf.m4',
@@ -218,8 +218,10 @@ libcore_la_sources = files('''
# install_data('user.conf',
# install_dir : pkgsysconfdir)
#
-# meson.add_install_script('sh', '-c', mkdir_p.format(systemshutdowndir))
-# meson.add_install_script('sh', '-c', mkdir_p.format(systemsleepdir))
+#endif // 0
+meson.add_install_script('sh', '-c', mkdir_p.format(systemshutdowndir))
+meson.add_install_script('sh', '-c', mkdir_p.format(systemsleepdir))
+#if 0 /// UNNEEDED by elogind
# meson.add_install_script('sh', '-c', mkdir_p.format(systemgeneratordir))
# meson.add_install_script('sh', '-c', mkdir_p.format(usergeneratordir))
#