summaryrefslogtreecommitdiff
path: root/src/libelogind
diff options
context:
space:
mode:
authorDavide Cavalca <dcavalca@fb.com>2018-04-09 02:43:35 -0700
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commit6be67d4563e4a6f51e5358121f6cd9d92ea5208b (patch)
treec02442bfbc781c15088625152fb221aaf4c2dfa0 /src/libelogind
parent4f05c22da5971ae52d8987d77746442f81ece573 (diff)
meson: add support for building static libsystemd and libudev
Diffstat (limited to 'src/libelogind')
-rw-r--r--src/libelogind/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/libelogind/meson.build b/src/libelogind/meson.build
index bacf323bd..b434b5ccf 100644
--- a/src/libelogind/meson.build
+++ b/src/libelogind/meson.build
@@ -130,18 +130,20 @@ libelogind_sources = files('''
#endif // 0
libelogind_static = static_library(
- 'elogind',
libelogind_sources,
+libelogind_c_args = ['-fvisibility=default']
+
+ 'elogind_static',
install : false,
include_directories : includes,
link_with : libbasic,
#if 0 /// elogind does not need librt
# dependencies : [threads,
# librt],
+# c_args : libsystemd_c_args)
#else
dependencies : [threads],
#endif // 0
- c_args : ['-fvisibility=default'])
libelogind_sym = 'src/libelogind/libelogind.sym'