summaryrefslogtreecommitdiff
path: root/src/login
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2018-08-10 17:41:29 +0200
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commit48d68297393c8b3699dd1ccabfe2e30b84c0a624 (patch)
tree013f7e15a1e949782803a64002ef188ee3b8d1c4 /src/login
parent11a069d1c3a71ea239275b1a1122d48ef9c45fb1 (diff)
Build system: Fix various issues that came from errornous migration.
No matter how much advanced check_tree.pl is, there are plenty possibilities where upstream changes can be transported wrong. Mainly adding something we then have to mask out. But at the end of the day this is actually wanted, so we do not miss important changes.
Diffstat (limited to 'src/login')
-rw-r--r--src/login/meson.build146
-rw-r--r--src/login/org.freedesktop.login1.policy (renamed from src/login/org.freedesktop.login1.policy.in)138
2 files changed, 122 insertions, 162 deletions
diff --git a/src/login/meson.build b/src/login/meson.build
index 2dfa648c3..59083e6fc 100644
--- a/src/login/meson.build
+++ b/src/login/meson.build
@@ -83,115 +83,79 @@ loginctl_sources = files('''
sysfs-show.c
'''.split())
+#if 0 /// UNNEEDED by elogind
+# user_runtime_dir_sources = files('''
+# user-runtime-dir.c
+# logind.h
+# '''.split())
+#endif // 0
+
#if 1 /// elogind has some additional files:
loginctl_sources += files('''
eloginctl.c
eloginctl.h
-user_runtime_dir_sources = files('''
- user-runtime-dir.c
- logind.h
'''.split())
#endif // 1
-#if 0 /// elogind builds itself unconditionally and with some adaptations
+#if 0 /// elogind builds itself unconditionally
# if conf.get('ENABLE_LOGIND') == 1
-# logind_conf = configure_file(
-# input : 'logind.conf.in',
-# output : 'logind.conf',
-# configuration : substs)
-# install_data(logind_conf,
-# install_dir : pkgsysconfdir)
-#
-# pam_systemd_sym = 'src/login/pam_systemd.sym'
-# pam_systemd_c = files('pam_systemd.c')
-#
-# install_data('org.freedesktop.login1.conf',
-# install_dir : dbuspolicydir)
+#endif // 0
+ logind_conf = configure_file(
+ input : 'logind.conf.in',
+ output : 'logind.conf',
+ configuration : substs)
+ install_data(logind_conf,
+ install_dir : pkgsysconfdir)
+
+ pam_elogind_sym = 'src/login/pam_elogind.sym'
+ pam_elogind_c = files('pam_elogind.c')
+
+ install_data('org.freedesktop.login1.conf',
+ install_dir : dbuspolicydir)
+#if 0 /// Works a bit differently here, as elogind alows dbus activation.
# install_data('org.freedesktop.login1.service',
# install_dir : dbussystemservicedir)
-# install_data('org.freedesktop.login1.policy',
-# install_dir : polkitpolicydir)
-#
-# install_data('70-power-switch.rules', install_dir : udevrulesdir)
-#
-# if conf.get('HAVE_ACL') == 1
-# install_data('70-uaccess.rules', install_dir : udevrulesdir)
-# endif
-#
-# seat_rules = configure_file(
-# input : '71-seat.rules.in',
-# output : '71-seat.rules',
-# configuration : substs)
-# install_data(seat_rules,
-# install_dir : udevrulesdir)
-#
-# custom_target(
-# '73-seat-late.rules',
-# input : '73-seat-late.rules.m4',
-# output: '73-seat-late.rules',
-# command : [meson_apply_m4, config_h, '@INPUT@'],
-# capture : true,
-# install : true,
-# install_dir : udevrulesdir)
-#
-# custom_target(
-# 'systemd-user',
-# input : 'systemd-user.m4',
-# output: 'systemd-user',
-# command : [meson_apply_m4, config_h, '@INPUT@'],
-# capture : true,
-# install : pamconfdir != 'no',
-# install_dir : pamconfdir)
-# endif
#else
-logind_conf = configure_file(
- input : 'logind.conf.in',
- output : 'logind.conf',
- configuration : substs)
-install_data(logind_conf,
- install_dir : pkgsysconfdir)
-
-pam_elogind_sym = 'src/login/pam_elogind.sym'
-pam_elogind_c = files('pam_elogind.c')
-
-install_data('org.freedesktop.login1.conf',
- install_dir : dbuspolicydir)
logind_service = configure_file(
input : 'org.freedesktop.login1.service.in',
output : 'org.freedesktop.login1.service',
configuration : substs)
install_data(logind_service,
install_dir : dbussystemservicedir)
+#endif // 0
+ install_data('org.freedesktop.login1.policy',
+ install_dir : polkitpolicydir)
-i18n.merge_file(
- 'org.freedesktop.login1.policy',
- input : 'org.freedesktop.login1.policy.in',
- output : 'org.freedesktop.login1.policy',
- po_dir : po_dir,
- data_dirs : po_dir,
- install : install_polkit,
- install_dir : polkitpolicydir)
-
-install_data('70-power-switch.rules',
- '70-uaccess.rules',
- install_dir : udevrulesdir)
+ install_data('70-power-switch.rules', install_dir : udevrulesdir)
+
+ if conf.get('HAVE_ACL') == 1
+ install_data('70-uaccess.rules', install_dir : udevrulesdir)
+ endif
-foreach file : ['71-seat.rules',
- '73-seat-late.rules']
- gen = configure_file(
- input : file + '.in',
- output : file,
+ seat_rules = configure_file(
+ input : '71-seat.rules.in',
+ output : '71-seat.rules',
configuration : substs)
- install_data(gen,
- install_dir : udevrulesdir)
-endforeach
-
-custom_target(
- 'elogind-user',
- input : 'elogind-user.m4',
- output: 'elogind-user',
- command : [m4, '-P'] + m4_defines + ['@INPUT@'],
- capture : true,
- install : pamconfdir != 'no',
- install_dir : pamconfdir)
+ install_data(seat_rules,
+ install_dir : udevrulesdir)
+
+ custom_target(
+ '73-seat-late.rules',
+ input : '73-seat-late.rules.m4',
+ output: '73-seat-late.rules',
+ command : [meson_apply_m4, config_h, '@INPUT@'],
+ capture : true,
+ install : true,
+ install_dir : udevrulesdir)
+
+ custom_target(
+ 'elogind-user',
+ input : 'elogind-user.m4',
+ output: 'elogind-user',
+ command : [meson_apply_m4, config_h, '@INPUT@'],
+ capture : true,
+ install : pamconfdir != 'no',
+ install_dir : pamconfdir)
+#if 0 /// elogind builds itself unconditionally
+# endif
#endif //0
diff --git a/src/login/org.freedesktop.login1.policy.in b/src/login/org.freedesktop.login1.policy
index 997a7d70f..f1d1f956d 100644
--- a/src/login/org.freedesktop.login1.policy.in
+++ b/src/login/org.freedesktop.login1.policy
@@ -3,11 +3,11 @@
"http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
<!--
- This file is part of elogind.
SPDX-License-Identifier: LGPL-2.1+
- elogind is free software; you can redistribute it and/or modify it
+ This file is part of systemd.
+ systemd is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License as published by
the Free Software Foundation; either version 2.1 of the License, or
(at your option) any later version.
@@ -15,16 +15,12 @@
<policyconfig>
- <vendor>The elogind Project</vendor>
- <!-- 0 /// Need to set this to the elogind project url
+ <vendor>The systemd Project</vendor>
<vendor_url>http://www.freedesktop.org/wiki/Software/systemd</vendor_url>
- --><!-- else -->
- <vendor_url>https://github.com/elogind/elogind</vendor_url>
- <!-- // 0 -->
<action id="org.freedesktop.login1.inhibit-block-shutdown">
- <description>Allow applications to inhibit system shutdown</description>
- <message>Authentication is required for an application to inhibit system shutdown.</message>
+ <description gettext-domain="systemd">Allow applications to inhibit system shutdown</description>
+ <message gettext-domain="systemd">Authentication is required for an application to inhibit system shutdown.</message>
<defaults>
<allow_any>no</allow_any>
<allow_inactive>yes</allow_inactive>
@@ -34,8 +30,8 @@
</action>
<action id="org.freedesktop.login1.inhibit-delay-shutdown">
- <description>Allow applications to delay system shutdown</description>
- <message>Authentication is required for an application to delay system shutdown.</message>
+ <description gettext-domain="systemd">Allow applications to delay system shutdown</description>
+ <message gettext-domain="systemd">Authentication is required for an application to delay system shutdown.</message>
<defaults>
<allow_any>yes</allow_any>
<allow_inactive>yes</allow_inactive>
@@ -45,8 +41,8 @@
</action>
<action id="org.freedesktop.login1.inhibit-block-sleep">
- <description>Allow applications to inhibit system sleep</description>
- <message>Authentication is required for an application to inhibit system sleep.</message>
+ <description gettext-domain="systemd">Allow applications to inhibit system sleep</description>
+ <message gettext-domain="systemd">Authentication is required for an application to inhibit system sleep.</message>
<defaults>
<allow_any>no</allow_any>
<allow_inactive>yes</allow_inactive>
@@ -56,8 +52,8 @@
</action>
<action id="org.freedesktop.login1.inhibit-delay-sleep">
- <description>Allow applications to delay system sleep</description>
- <message>Authentication is required for an application to delay system sleep.</message>
+ <description gettext-domain="systemd">Allow applications to delay system sleep</description>
+ <message gettext-domain="systemd">Authentication is required for an application to delay system sleep.</message>
<defaults>
<allow_any>yes</allow_any>
<allow_inactive>yes</allow_inactive>
@@ -66,8 +62,8 @@
</action>
<action id="org.freedesktop.login1.inhibit-block-idle">
- <description>Allow applications to inhibit automatic system suspend</description>
- <message>Authentication is required for an application to inhibit automatic system suspend.</message>
+ <description gettext-domain="systemd">Allow applications to inhibit automatic system suspend</description>
+ <message gettext-domain="systemd">Authentication is required for an application to inhibit automatic system suspend.</message>
<defaults>
<allow_any>yes</allow_any>
<allow_inactive>yes</allow_inactive>
@@ -76,8 +72,8 @@
</action>
<action id="org.freedesktop.login1.inhibit-handle-power-key">
- <description>Allow applications to inhibit system handling of the power key</description>
- <message>Authentication is required for an application to inhibit system handling of the power key.</message>
+ <description gettext-domain="systemd">Allow applications to inhibit system handling of the power key</description>
+ <message gettext-domain="systemd">Authentication is required for an application to inhibit system handling of the power key.</message>
<defaults>
<allow_any>no</allow_any>
<allow_inactive>yes</allow_inactive>
@@ -87,8 +83,8 @@
</action>
<action id="org.freedesktop.login1.inhibit-handle-suspend-key">
- <description>Allow applications to inhibit system handling of the suspend key</description>
- <message>Authentication is required for an application to inhibit system handling of the suspend key.</message>
+ <description gettext-domain="systemd">Allow applications to inhibit system handling of the suspend key</description>
+ <message gettext-domain="systemd">Authentication is required for an application to inhibit system handling of the suspend key.</message>
<defaults>
<allow_any>no</allow_any>
<allow_inactive>yes</allow_inactive>
@@ -98,8 +94,8 @@
</action>
<action id="org.freedesktop.login1.inhibit-handle-hibernate-key">
- <description>Allow applications to inhibit system handling of the hibernate key</description>
- <message>Authentication is required for an application to inhibit system handling of the hibernate key.</message>
+ <description gettext-domain="systemd">Allow applications to inhibit system handling of the hibernate key</description>
+ <message gettext-domain="systemd">Authentication is required for an application to inhibit system handling of the hibernate key.</message>
<defaults>
<allow_any>no</allow_any>
<allow_inactive>yes</allow_inactive>
@@ -108,8 +104,8 @@
</action>
<action id="org.freedesktop.login1.inhibit-handle-lid-switch">
- <description>Allow applications to inhibit system handling of the lid switch</description>
- <message>Authentication is required for an application to inhibit system handling of the lid switch.</message>
+ <description gettext-domain="systemd">Allow applications to inhibit system handling of the lid switch</description>
+ <message gettext-domain="systemd">Authentication is required for an application to inhibit system handling of the lid switch.</message>
<defaults>
<allow_any>no</allow_any>
<allow_inactive>yes</allow_inactive>
@@ -118,8 +114,8 @@
</action>
<action id="org.freedesktop.login1.set-self-linger">
- <description>Allow non-logged-in user to run programs</description>
- <message>Explicit request is required to run programs as a non-logged-in user.</message>
+ <description gettext-domain="systemd">Allow non-logged-in user to run programs</description>
+ <message gettext-domain="systemd">Explicit request is required to run programs as a non-logged-in user.</message>
<defaults>
<allow_any>yes</allow_any>
<allow_inactive>yes</allow_inactive>
@@ -128,8 +124,8 @@
</action>
<action id="org.freedesktop.login1.set-user-linger">
- <description>Allow non-logged-in users to run programs</description>
- <message>Authentication is required to run programs as a non-logged-in user.</message>
+ <description gettext-domain="systemd">Allow non-logged-in users to run programs</description>
+ <message gettext-domain="systemd">Authentication is required to run programs as a non-logged-in user.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -138,8 +134,8 @@
</action>
<action id="org.freedesktop.login1.attach-device">
- <description>Allow attaching devices to seats</description>
- <message>Authentication is required for attaching a device to a seat.</message>
+ <description gettext-domain="systemd">Allow attaching devices to seats</description>
+ <message gettext-domain="systemd">Authentication is required for attaching a device to a seat.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -149,8 +145,8 @@
</action>
<action id="org.freedesktop.login1.flush-devices">
- <description>Flush device to seat attachments</description>
- <message>Authentication is required for resetting how devices are attached to seats.</message>
+ <description gettext-domain="systemd">Flush device to seat attachments</description>
+ <message gettext-domain="systemd">Authentication is required for resetting how devices are attached to seats.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -159,8 +155,8 @@
</action>
<action id="org.freedesktop.login1.power-off">
- <description>Power off the system</description>
- <message>Authentication is required for powering off the system.</message>
+ <description gettext-domain="systemd">Power off the system</description>
+ <message gettext-domain="systemd">Authentication is required for powering off the system.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -170,8 +166,8 @@
</action>
<action id="org.freedesktop.login1.power-off-multiple-sessions">
- <description>Power off the system while other users are logged in</description>
- <message>Authentication is required for powering off the system while other users are logged in.</message>
+ <description gettext-domain="systemd">Power off the system while other users are logged in</description>
+ <message gettext-domain="systemd">Authentication is required for powering off the system while other users are logged in.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -181,8 +177,8 @@
</action>
<action id="org.freedesktop.login1.power-off-ignore-inhibit">
- <description>Power off the system while an application asked to inhibit it</description>
- <message>Authentication is required for powering off the system while an application asked to inhibit it.</message>
+ <description gettext-domain="systemd">Power off the system while an application asked to inhibit it</description>
+ <message gettext-domain="systemd">Authentication is required for powering off the system while an application asked to inhibit it.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -192,8 +188,8 @@
</action>
<action id="org.freedesktop.login1.reboot">
- <description>Reboot the system</description>
- <message>Authentication is required for rebooting the system.</message>
+ <description gettext-domain="systemd">Reboot the system</description>
+ <message gettext-domain="systemd">Authentication is required for rebooting the system.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -203,8 +199,8 @@
</action>
<action id="org.freedesktop.login1.reboot-multiple-sessions">
- <description>Reboot the system while other users are logged in</description>
- <message>Authentication is required for rebooting the system while other users are logged in.</message>
+ <description gettext-domain="systemd">Reboot the system while other users are logged in</description>
+ <message gettext-domain="systemd">Authentication is required for rebooting the system while other users are logged in.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -214,8 +210,8 @@
</action>
<action id="org.freedesktop.login1.reboot-ignore-inhibit">
- <description>Reboot the system while an application asked to inhibit it</description>
- <message>Authentication is required for rebooting the system while an application asked to inhibit it.</message>
+ <description gettext-domain="systemd">Reboot the system while an application asked to inhibit it</description>
+ <message gettext-domain="systemd">Authentication is required for rebooting the system while an application asked to inhibit it.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -225,8 +221,8 @@
</action>
<action id="org.freedesktop.login1.halt">
- <description>Halt the system</description>
- <message>Authentication is required for halting the system.</message>
+ <description gettext-domain="systemd">Halt the system</description>
+ <message gettext-domain="systemd">Authentication is required for halting the system.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -236,8 +232,8 @@
</action>
<action id="org.freedesktop.login1.halt-multiple-sessions">
- <description>Halt the system while other users are logged in</description>
- <message>Authentication is required for halting the system while other users are logged in.</message>
+ <description gettext-domain="systemd">Halt the system while other users are logged in</description>
+ <message gettext-domain="systemd">Authentication is required for halting the system while other users are logged in.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -247,8 +243,8 @@
</action>
<action id="org.freedesktop.login1.halt-ignore-inhibit">
- <description>Halt the system while an application asked to inhibit it</description>
- <message>Authentication is required for halting the system while an application asked to inhibit it.</message>
+ <description gettext-domain="systemd">Halt the system while an application asked to inhibit it</description>
+ <message gettext-domain="systemd">Authentication is required for halting the system while an application asked to inhibit it.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -258,8 +254,8 @@
</action>
<action id="org.freedesktop.login1.suspend">
- <description>Suspend the system</description>
- <message>Authentication is required for suspending the system.</message>
+ <description gettext-domain="systemd">Suspend the system</description>
+ <message gettext-domain="systemd">Authentication is required for suspending the system.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -268,8 +264,8 @@
</action>
<action id="org.freedesktop.login1.suspend-multiple-sessions">
- <description>Suspend the system while other users are logged in</description>
- <message>Authentication is required for suspending the system while other users are logged in.</message>
+ <description gettext-domain="systemd">Suspend the system while other users are logged in</description>
+ <message gettext-domain="systemd">Authentication is required for suspending the system while other users are logged in.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -279,8 +275,8 @@
</action>
<action id="org.freedesktop.login1.suspend-ignore-inhibit">
- <description>Suspend the system while an application asked to inhibit it</description>
- <message>Authentication is required for suspending the system while an application asked to inhibit it.</message>
+ <description gettext-domain="systemd">Suspend the system while an application asked to inhibit it</description>
+ <message gettext-domain="systemd">Authentication is required for suspending the system while an application asked to inhibit it.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -290,8 +286,8 @@
</action>
<action id="org.freedesktop.login1.hibernate">
- <description>Hibernate the system</description>
- <message>Authentication is required for hibernating the system.</message>
+ <description gettext-domain="systemd">Hibernate the system</description>
+ <message gettext-domain="systemd">Authentication is required for hibernating the system.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -300,8 +296,8 @@
</action>
<action id="org.freedesktop.login1.hibernate-multiple-sessions">
- <description>Hibernate the system while other users are logged in</description>
- <message>Authentication is required for hibernating the system while other users are logged in.</message>
+ <description gettext-domain="systemd">Hibernate the system while other users are logged in</description>
+ <message gettext-domain="systemd">Authentication is required for hibernating the system while other users are logged in.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -311,8 +307,8 @@
</action>
<action id="org.freedesktop.login1.hibernate-ignore-inhibit">
- <description>Hibernate the system while an application asked to inhibit it</description>
- <message>Authentication is required for hibernating the system while an application asked to inhibit it.</message>
+ <description gettext-domain="systemd">Hibernate the system while an application asked to inhibit it</description>
+ <message gettext-domain="systemd">Authentication is required for hibernating the system while an application asked to inhibit it.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -322,8 +318,8 @@
</action>
<action id="org.freedesktop.login1.manage">
- <description>Manage active sessions, users and seats</description>
- <message>Authentication is required for managing active sessions, users and seats.</message>
+ <description gettext-domain="systemd">Manage active sessions, users and seats</description>
+ <message gettext-domain="systemd">Authentication is required for managing active sessions, users and seats.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -332,8 +328,8 @@
</action>
<action id="org.freedesktop.login1.lock-sessions">
- <description>Lock or unlock active sessions</description>
- <message>Authentication is required to lock or unlock active sessions.</message>
+ <description gettext-domain="systemd">Lock or unlock active sessions</description>
+ <message gettext-domain="systemd">Authentication is required to lock or unlock active sessions.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -342,8 +338,8 @@
</action>
<action id="org.freedesktop.login1.set-reboot-to-firmware-setup">
- <description>Allow indication to the firmware to boot to setup interface</description>
- <message>Authentication is required to indicate to the firmware to boot to setup interface.</message>
+ <description gettext-domain="systemd">Allow indication to the firmware to boot to setup interface</description>
+ <message gettext-domain="systemd">Authentication is required to indicate to the firmware to boot to setup interface.</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>
@@ -352,8 +348,8 @@
</action>
<action id="org.freedesktop.login1.set-wall-message">
- <description>Set a wall message</description>
- <message>Authentication is required to set a wall message</message>
+ <description gettext-domain="systemd">Set a wall message</description>
+ <message gettext-domain="systemd">Authentication is required to set a wall message</message>
<defaults>
<allow_any>auth_admin_keep</allow_any>
<allow_inactive>auth_admin_keep</allow_inactive>