summaryrefslogtreecommitdiff
path: root/src/shared/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-10-03 10:41:51 +0200
committerSven Eden <yamakuzure@gmx.net>2017-11-23 08:11:42 +0100
commit3344b839df8fe2dd2b4a4f470225e4c407cf2faa (patch)
treea64c86cfe6adc5718143f5604fef893cfd94a865 /src/shared/meson.build
parent7d729de3a70bc7a7fef69f5cea03fcbf835e118a (diff)
build-sys: use #if Y instead of #ifdef Y everywhere
The advantage is that is the name is mispellt, cpp will warn us. $ git grep -Ee "conf.set\('(HAVE|ENABLE)_" -l|xargs sed -r -i "s/conf.set\('(HAVE|ENABLE)_/conf.set10('\1_/" $ git grep -Ee '#ifn?def (HAVE|ENABLE)' -l|xargs sed -r -i 's/#ifdef (HAVE|ENABLE)/#if \1/; s/#ifndef (HAVE|ENABLE)/#if ! \1/;' $ git grep -Ee 'if.*defined\(HAVE' -l|xargs sed -i -r 's/defined\((HAVE_[A-Z0-9_]*)\)/\1/g' $ git grep -Ee 'if.*defined\(ENABLE' -l|xargs sed -i -r 's/defined\((ENABLE_[A-Z0-9_]*)\)/\1/g' + manual changes to meson.build squash! build-sys: use #if Y instead of #ifdef Y everywhere v2: - fix incorrect setting of HAVE_LIBIDN2
Diffstat (limited to 'src/shared/meson.build')
-rw-r--r--src/shared/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/shared/meson.build b/src/shared/meson.build
index 06ecaf633..172f55ba7 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -127,20 +127,20 @@ shared_sources = '''
test_tables_h = files('test-tables.h')
shared_sources += [test_tables_h]
-if conf.get('HAVE_ACL', false)
+if conf.get('HAVE_ACL') == 1
shared_sources += ['acl-util.c']
endif
-if conf.get('HAVE_UTMP', false)
+if conf.get('HAVE_UTMP') == 1
shared_sources += ['utmp-wtmp.c']
endif
#if 0 /// UNNEEDED by elogind
-# if conf.get('HAVE_SECCOMP', false)
+# if conf.get('HAVE_SECCOMP') == 1
# shared_sources += ['seccomp-util.c']
# endif
#
-# if conf.get('HAVE_LIBIPTC', false)
+# if conf.get('HAVE_LIBIPTC') == 1
# shared_sources += ['firewall-util.c']
# endif
#endif // 0