summaryrefslogtreecommitdiff
path: root/src/shared/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-07-22 23:25:07 +0900
committerSven Eden <sven.eden@prydeworx.com>2018-10-29 10:18:23 +0100
commit4185280dffbfb67db3cc1b9c3ccbedede37e0b7c (patch)
tree37385938fafbb7c744c6af29a7980607a734d113 /src/shared/meson.build
parent9db5b384fe18fb48edb89df5eab2633251f29ffb (diff)
meson: do not build module-util.c when libkmod is not found
Follow-up for 3cb9b42af3b205fba176ebf51ce0e07739698278 (#9516). Fixes oss-fuzz-9532. (cherry picked from commit ba323bbead1dda558a5bbe42846cdee5c8b0fc85)
Diffstat (limited to 'src/shared/meson.build')
-rw-r--r--src/shared/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/shared/meson.build b/src/shared/meson.build
index 9f4615091..e5cd4d60c 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -65,7 +65,6 @@
# machine-pool.c
# machine-pool.h
# module-util.h
-# module-util.c
# nsflags.c
# nsflags.h
# output-mode.c
@@ -150,6 +149,10 @@ endif
#endif // 0
libshared_name = 'elogind-shared-@0@'.format(meson.project_version())
+if conf.get('HAVE_KMOD') == 1
+ shared_sources += files('module-util.c')
+endif
+
#if 0 /// elogind doesn't need all this
# libshared_deps = [threads,