summaryrefslogtreecommitdiff
path: root/src/systemd
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-28 09:07:36 +0200
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commitc5051c2fdb95adf81d25af05eb4a8851f041b5f5 (patch)
treec53bc37faf108675ea7183bb4cc543498aaec3b0 /src/systemd
parent60e01864df295d7ef54c737a9283b4a10fe2feb9 (diff)
meson: test out headers with more standard versions
They all pass fine, but let's keep testing regularly.
Diffstat (limited to 'src/systemd')
-rw-r--r--src/systemd/meson.build17
1 files changed, 15 insertions, 2 deletions
diff --git a/src/systemd/meson.build b/src/systemd/meson.build
index c3f82dc50..18df81cf2 100644
--- a/src/systemd/meson.build
+++ b/src/systemd/meson.build
@@ -66,11 +66,24 @@ meson.add_install_script(meson_symlink_headers,
opts = [['c'],
['c', '-ansi'],
- ['c', '-std=iso9899:1990']]
+ ['c', '-std=iso9899:1990'],
+ ['c', '-std=iso9899:2011']]
+
+if cc.has_argument('-std=iso9899:2017')
+ opts += [['c', '-std=iso9899:2017']]
+endif
cxx = find_program('c++', required : false)
if cxx.found()
- opts += [['c++']]
+ opts += [['c++'],
+ ['c++', '-std=c++98'],
+ ['c++', '-std=c++11']]
+ if cc.has_argument('-std=c++14')
+ opts += [['c++', '-std=c++14']]
+ endif
+ if cc.has_argument('-std=c++17')
+ opts += [['c++', '-std=c++17']]
+ endif
endif
foreach header : _systemd_headers