summaryrefslogtreecommitdiff
path: root/src/test/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-03-26 16:32:40 +0200
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commit2cefb09ff69c3595e98c55f0da1bd137c612276c (patch)
tree413850b2eb4d2cd031c2d31ef66b657baf5d66d4 /src/test/meson.build
parent1049fbda947f856942a693f011fe013a2ee798f0 (diff)
os-util: add helpers for finding /etc/os-release
Place this new helpers in a new source file os-util.[ch], and move the existing and related call path_is_os_tree() to it as well.
Diffstat (limited to 'src/test/meson.build')
-rw-r--r--src/test/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index 833634ffa..8d694b379 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -264,6 +264,10 @@ tests += [
[],
[]],
+ [['src/test/test-os-util.c'],
+ [],
+ []],
+
[['src/test/test-escape.c'],
[],
[]],
@@ -956,6 +960,7 @@ tests += [
# 'src/libsystemd-network/dhcp-internal.h'],
# [libshared,
# libelogind_network],
+# libsystemd_network],
# []],
#
# [['src/libsystemd-network/test-sd-dhcp-lease.c',
@@ -970,11 +975,13 @@ tests += [
# 'src/systemd/sd-dhcp-client.h'],
# [libshared,
# libelogind_network],
+# libsystemd_network],
# []],
#
# [['src/libelogind-network/test-dhcp-server.c'],
# [libshared,
# libelogind_network],
+# libsystemd_network],
# []],
#
# [['src/libsystemd-network/test-ipv4ll.c',
@@ -982,12 +989,14 @@ tests += [
# 'src/systemd/sd-ipv4ll.h'],
# [libshared,
# libelogind_network],
+# libsystemd_network],
# []],
#
# [['src/libelogind-network/test-ipv4ll-manual.c',
# 'src/systemd/sd-ipv4ll.h'],
# [libshared,
# libelogind_network],
+# libsystemd_network],
# [],
# '', 'manual'],
#
@@ -1006,6 +1015,7 @@ tests += [
# 'src/systemd/sd-ndisc.h'],
# [libshared,
# libelogind_network],
+# libsystemd_network],
# []],
#
# [['src/libsystemd-network/test-ndisc-ra.c',
@@ -1022,6 +1032,7 @@ tests += [
# 'src/systemd/sd-dhcp6-client.h'],
# [libshared,
# libelogind_network],
+# libsystemd_network],
# []],
#
# [['src/libelogind-network/test-lldp.c'],