summaryrefslogtreecommitdiff
path: root/src/test/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-02-05 09:48:38 +0100
committerSven Eden <yamakuzure@gmx.net>2018-05-30 07:53:59 +0200
commit34e3453d337962906b7f3bbe6285b26ae6600173 (patch)
tree31186a06e9fb7055ec618b2c203fc6533d3fc8e9 /src/test/meson.build
parent8ec4048e023eb6b020f83eeade9fb3a6964db17d (diff)
test: add a simple smoke test for string_hashsum()
This is enough to show memory leakages pointed out by Stef Bon <stefbon@gmail.com>. (cherry picked from commit bd181f27d4d0c16c500c9f49394213d1fbad1f09)
Diffstat (limited to 'src/test/meson.build')
-rw-r--r--src/test/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index 72fb33d9a..12dfcf5ad 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -409,6 +409,17 @@ tests += [
# libblkid]],
#endif // 0
+ [['src/test/test-watch-pid.c',
+ 'src/test/test-helper.c'],
+ [libcore,
+ libshared],
+ [libmount,
+ threads,
+ librt,
+ libseccomp,
+ libselinux,
+ libblkid]],
+
[['src/test/test-hashmap.c',
'src/test/test-hashmap-plain.c',
test_hashmap_ordered_c],
@@ -434,6 +445,10 @@ tests += [
[],
[]],
+ [['src/test/test-procfs-util.c'],
+ [],
+ []],
+
[['src/test/test-unaligned.c'],
[],
[]],
@@ -681,6 +696,11 @@ tests += [
[],
[]],
+ [['src/test/test-gcrypt-util.c'],
+ [],
+ [],
+ 'HAVE_GCRYPT'],
+
#if 0 /// UNNEEDED in elogind
# [['src/test/test-nss.c'],
# [],