summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-08-20 09:21:04 +0200
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:07:23 +0100
commit338ea72012c43c5fc7fb0dfda10dc1c462d3111e (patch)
tree055ed3be154aaec9bb336954fe0049af61f0004c /src
parentb5132cc290ef609fb7a84adb8130526fb433c291 (diff)
Create /run/systemd as needed
* src/login/logind.c (main): Also create /run/systemd at startup. * configure.ac: Bump to 219.3.
Diffstat (limited to 'src')
-rw-r--r--src/login/logind.c1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/login/logind.c b/src/login/logind.c
index a83d9443d..f84938a7f 100644
--- a/src/login/logind.c
+++ b/src/login/logind.c
@@ -1153,6 +1153,7 @@ int main(int argc, char *argv[]) {
* existence of /run/systemd/seats/ to determine whether
* logind is available, so please always make sure this check
* stays in. */
+ mkdir_label("/run/systemd", 0755);
mkdir_label("/run/systemd/seats", 0755);
mkdir_label("/run/systemd/users", 0755);
mkdir_label("/run/systemd/sessions", 0755);