summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2018-06-01 20:22:28 +0200
committerSven Eden <yamakuzure@gmx.net>2018-06-04 10:32:31 +0200
commit5787907ce78450bac5487d8a56d702d31ea1e9e9 (patch)
tree8d5b6f1a5c6b415ac86d6779487536626b98177a /src
parent8290b1a8c9471da570ebc6e58fd837c59265a19a (diff)
Prep v238: Fixed meson.build files in src/shared and src/test
Diffstat (limited to 'src')
-rw-r--r--src/shared/meson.build46
-rw-r--r--src/test/meson.build34
2 files changed, 39 insertions, 41 deletions
diff --git a/src/shared/meson.build b/src/shared/meson.build
index 2c70bfd41..341eb52cb 100644
--- a/src/shared/meson.build
+++ b/src/shared/meson.build
@@ -57,8 +57,6 @@
# firewall-util.h
# fstab-util.c
# fstab-util.h
-# gcrypt-util.c
-# gcrypt-util.h
# generator.c
# generator.h
# gpt.h
@@ -194,31 +192,31 @@ libshared_deps = [threads,
libshared_sym_path = '@0@/libshared.sym'.format(meson.current_source_dir())
-libshared = shared_library(
+libshared_static = static_library(
libshared_name,
shared_sources,
- basic_sources,
- journal_internal_sources,
- libelogind_internal_sources,
+ include_directories : includes,
+ dependencies : libshared_deps,
+ c_args : ['-fvisibility=default'])
+
+libshared = shared_library(
+ libshared_name,
#if 0 /// UNNEEDED by elogind
# libudev_sources,
-# include_directories : includes,
-# link_args : ['-shared',
-# '-Wl,--version-script=' + libshared_sym_path],
-# c_args : ['-fvisibility=default'],
-# dependencies : libshared_deps,
-# install : true,
-# install_dir : rootlibexecdir)
-#
-# libshared_static = static_library(
-# libshared_name,
-# shared_sources,
-# basic_sources,
-# include_directories : includes,
-# dependencies : libshared_deps)
+#endif // 0
+ include_directories : includes,
+ link_args : ['-shared',
+ '-Wl,--version-script=' + libshared_sym_path],
+ link_whole : [libshared_static,
+ libbasic,
+#if 0 /// UNNEEDED by elogind
+# libbasic_gcrypt,
+# libsystemd_static,
+# libjournal_client],
#else
- libelogind_internal_sources,
+ libelogind_static],
#endif // 0
-#if 1 /// need elogind internal library sources
- libelogind_internal_sources,
-#endif // 1
+ c_args : ['-fvisibility=default'],
+ dependencies : libshared_deps,
+ install : true,
+ install_dir : rootlibexecdir)
diff --git a/src/test/meson.build b/src/test/meson.build
index 12dfcf5ad..5cc5c4fb0 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -59,8 +59,8 @@ test_dlopen_c = files('test-dlopen.c')
############################################################
#if 0 /// UNNEEDED by elogind
+# test_systemd_tmpfiles_py = find_program('test-systemd-tmpfiles.py')
#endif // 0
-test_elogind_tmpfiles_py = find_program('test-elogind-tmpfiles.py')
############################################################
@@ -407,19 +407,19 @@ tests += [
# libseccomp,
# libselinux,
# libblkid]],
+#
+# [['src/test/test-watch-pid.c',
+# 'src/test/test-helper.c'],
+# [libcore,
+# libshared],
+# [libmount,
+# threads,
+# librt,
+# libseccomp,
+# libselinux,
+# libblkid]],
#endif // 0
- [['src/test/test-watch-pid.c',
- 'src/test/test-helper.c'],
- [libcore,
- libshared],
- [libmount,
- threads,
- librt,
- libseccomp,
- libselinux,
- libblkid]],
-
[['src/test/test-hashmap.c',
'src/test/test-hashmap-plain.c',
test_hashmap_ordered_c],
@@ -696,12 +696,12 @@ tests += [
[],
[]],
- [['src/test/test-gcrypt-util.c'],
- [],
- [],
- 'HAVE_GCRYPT'],
-
#if 0 /// UNNEEDED in elogind
+# [['src/test/test-gcrypt-util.c'],
+# [],
+# [],
+# 'HAVE_GCRYPT'],
+#
# [['src/test/test-nss.c'],
# [],
# [libdl],