summaryrefslogtreecommitdiff
path: root/units/user
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-11-15 22:12:41 +0100
committerLennart Poettering <lennart@poettering.net>2010-11-15 22:13:26 +0100
commitaf2d49f70bcff20efaf2d69aecaf4b3e898ff1fa (patch)
tree3b2e21237d67459424f5e276dda07a9be3575e62 /units/user
parent62347bc24a695bc0527f663af5fe136b1a993573 (diff)
drop support for MANAGER_SESSION, introduce MANAGER_USER instead
Diffstat (limited to 'units/user')
-rw-r--r--units/user/.gitignore1
l---------units/user/Makefile1
-rw-r--r--units/user/default.target11
-rw-r--r--units/user/exit.service.in18
-rw-r--r--units/user/exit.target18
5 files changed, 49 insertions, 0 deletions
diff --git a/units/user/.gitignore b/units/user/.gitignore
new file mode 100644
index 000000000..eeb62b32b
--- /dev/null
+++ b/units/user/.gitignore
@@ -0,0 +1 @@
+exit.service
diff --git a/units/user/Makefile b/units/user/Makefile
new file mode 120000
index 000000000..50be21181
--- /dev/null
+++ b/units/user/Makefile
@@ -0,0 +1 @@
+../../src/Makefile \ No newline at end of file
diff --git a/units/user/default.target b/units/user/default.target
new file mode 100644
index 000000000..deb310c2f
--- /dev/null
+++ b/units/user/default.target
@@ -0,0 +1,11 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+# See systemd.special(7) for details
+
+[Unit]
+Description=Default
diff --git a/units/user/exit.service.in b/units/user/exit.service.in
new file mode 100644
index 000000000..a20b089c9
--- /dev/null
+++ b/units/user/exit.service.in
@@ -0,0 +1,18 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+# See systemd.special(7) for details
+
+[Unit]
+Description=Exit the Session
+DefaultDependencies=no
+Requires=shutdown.target
+After=shutdown.target
+
+[Service]
+Type=oneshot
+ExecStart=@SYSTEMCTL@ --user --force exit
diff --git a/units/user/exit.target b/units/user/exit.target
new file mode 100644
index 000000000..f34844c0d
--- /dev/null
+++ b/units/user/exit.target
@@ -0,0 +1,18 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+# See systemd.special(7) for details
+
+[Unit]
+Description=Exit the Session
+DefaultDependencies=no
+Requires=exit.service
+After=exit.service
+AllowIsolate=yes
+
+[Install]
+Alias=ctrl-alt-del.target