summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am52
-rw-r--r--po/.gitignore1
-rw-r--r--po/POTFILES.skip2
-rw-r--r--src/hostname/hostnamed.c (renamed from src/hostnamed.c)0
4 files changed, 28 insertions, 27 deletions
diff --git a/Makefile.am b/Makefile.am
index cc28e2abb..c6a25a78e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -202,11 +202,6 @@ rootlibexec_PROGRAMS += \
systemd-binfmt
endif
-if ENABLE_HOSTNAMED
-rootlibexec_PROGRAMS += \
- systemd-hostnamed
-endif
-
systemgenerator_PROGRAMS = \
systemd-getty-generator
@@ -428,11 +423,6 @@ nodist_systemunit_DATA += \
units/systemd-binfmt.service
endif
-if ENABLE_HOSTNAMED
-nodist_systemunit_DATA += \
- units/systemd-hostnamed.service
-endif
-
dist_userunit_DATA = \
units/user/default.target \
units/user/exit.target
@@ -492,11 +482,6 @@ EXTRA_DIST += \
units/systemd-binfmt.service.in
endif
-if ENABLE_HOSTNAMED
-EXTRA_DIST += \
- units/systemd-hostnamed.service.in
-endif
-
if TARGET_FEDORA
dist_systemunit_DATA += \
units/fedora/prefdm.service \
@@ -1100,8 +1085,10 @@ dist_pkgdata_DATA = \
dist_noinst_SCRIPT = \
src/generate-kbd-model-map
+# ------------------------------------------------------------------------------
+if ENABLE_HOSTNAMED
systemd_hostnamed_SOURCES = \
- src/hostnamed.c \
+ src/hostname/hostnamed.c \
src/dbus-common.c \
src/polkit.c
@@ -1114,6 +1101,29 @@ systemd_hostnamed_LDADD = \
libsystemd-daemon.la \
$(DBUS_LIBS)
+rootlibexec_PROGRAMS += \
+ systemd-hostnamed
+
+nodist_systemunit_DATA += \
+ units/systemd-hostnamed.service
+
+org.freedesktop.hostname1.xml: systemd-hostnamed
+ $(AM_V_GEN)$(LIBTOOL) --mode=execute $(OBJCOPY) -O binary -j introspect.hostname1 $< $@.tmp && \
+ $(STRINGS) $@.tmp | $(AWK) -f $(srcdir)/introspect.awk | \
+ $(DBUS_PREPROCESS) -o $@ - && rm $@.tmp
+
+hostnamed-install-data-hook:
+ ( cd $(DESTDIR)$(systemunitdir) && \
+ rm -f dbus-org.freedesktop.hostname1.service && \
+ $(LN_S) systemd-hostnamed.service dbus-org.freedesktop.hostname1.service )
+
+INSTALL_DATA_HOOKS += \
+ hostnamed-install-data-hook
+
+EXTRA_DIST += \
+ units/systemd-hostnamed.service.in
+endif
+
# ------------------------------------------------------------------------------
if ENABLE_LOCALED
systemd_localed_SOURCES = \
@@ -2040,11 +2050,6 @@ org.freedesktop.systemd1.%.xml: systemd
$(STRINGS) $@.tmp | $(AWK) -f $(srcdir)/introspect.awk | \
$(DBUS_PREPROCESS) -o $@ - && rm $@.tmp
-org.freedesktop.hostname1.xml: systemd-hostnamed
- $(AM_V_GEN)$(LIBTOOL) --mode=execute $(OBJCOPY) -O binary -j introspect.hostname1 $< $@.tmp && \
- $(STRINGS) $@.tmp | $(AWK) -f $(srcdir)/introspect.awk | \
- $(DBUS_PREPROCESS) -o $@ - && rm $@.tmp
-
CLEANFILES += \
$(dbusinterface_DATA)
@@ -2196,11 +2201,6 @@ if ENABLE_BINFMT
$(LN_S) ../systemd-binfmt.service systemd-binfmt.service && \
$(LN_S) ../proc-sys-fs-binfmt_misc.automount proc-sys-fs-binfmt_misc.automount )
endif
-if ENABLE_HOSTNAMED
- ( cd $(DESTDIR)$(systemunitdir) && \
- rm -f dbus-org.freedesktop.hostname1.service && \
- $(LN_S) systemd-hostnamed.service dbus-org.freedesktop.hostname1.service )
-endif
( cd $(DESTDIR)$(systemunitdir)/basic.target.wants && \
rm -f systemd-tmpfiles-clean.timer && \
$(LN_S) ../systemd-tmpfiles-clean.timer systemd-tmpfiles-clean.timer )
diff --git a/po/.gitignore b/po/.gitignore
index ee1215654..1fa8d3fd5 100644
--- a/po/.gitignore
+++ b/po/.gitignore
@@ -2,3 +2,4 @@ POTFILES
Makefile.in.in
.intltool-merge-cache
Makefile
+systemd.pot
diff --git a/po/POTFILES.skip b/po/POTFILES.skip
index 10d61410f..5a5d02749 100644
--- a/po/POTFILES.skip
+++ b/po/POTFILES.skip
@@ -11,7 +11,7 @@ src/dbus-swap.c
src/dbus-target.c
src/dbus-timer.c
src/dbus-unit.c
-src/hostnamed.c
+src/hostname/hostnamed.c
src/locale/localed.c
src/org.freedesktop.systemd1.policy.in.in
src/timedate/timedated.c
diff --git a/src/hostnamed.c b/src/hostname/hostnamed.c
index f3b2c9417..f3b2c9417 100644
--- a/src/hostnamed.c
+++ b/src/hostname/hostnamed.c