summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--man/systemd.special.xml34
-rw-r--r--units/nss-lookup.target2
-rw-r--r--units/nss-user-lookup.target15
-rw-r--r--units/remote-fs-pre.target2
-rw-r--r--units/systemd-logind.service.in1
6 files changed, 47 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e9e23175..0aebeb2d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -290,6 +290,7 @@ dist_systemunit_DATA = \
units/remote-fs-pre.target \
units/network.target \
units/nss-lookup.target \
+ units/nss-user-lookup.target \
units/mail-transfer-agent.target \
units/http-daemon.target \
units/poweroff.target \
diff --git a/man/systemd.special.xml b/man/systemd.special.xml
index fe85137ff..4c64a0fef 100644
--- a/man/systemd.special.xml
+++ b/man/systemd.special.xml
@@ -383,17 +383,39 @@
<varlistentry>
<term><filename>nss-lookup.target</filename></term>
<listitem>
- <para>systemd automatically
- adds dependencies of type
- After for this target unit to
- all SysV init script service
- units with an LSB header
- referring to the
+ <para>A target that should be
+ used as synchronization point
+ for all host/network name
+ service lookups. Note that
+ this is independent of
+ user/group name lookups for
+ which
+ <filename>nss-user-lookup.target</filename>
+ should be used. systemd
+ automatically adds
+ dependencies of type After for
+ this target unit to all SysV
+ init script service units with
+ an LSB header referring to the
<literal>$named</literal>
facility.</para>
</listitem>
</varlistentry>
<varlistentry>
+ <term><filename>nss-user-lookup.target</filename></term>
+ <listitem>
+ <para>A target that should be
+ used as synchronization point
+ for all user/group name
+ service lookups. Note that
+ this is independent of
+ host/network name lookups for
+ which
+ <filename>nss-lookup.target</filename>
+ should be used. </para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
<term><filename>poweroff.target</filename></term>
<listitem>
<para>A special target unit
diff --git a/units/nss-lookup.target b/units/nss-lookup.target
index bdca03cd8..f7b0b5c95 100644
--- a/units/nss-lookup.target
+++ b/units/nss-lookup.target
@@ -11,5 +11,5 @@
# implementations lacking socket/bus activation.
[Unit]
-Description=Name Lookups
+Description=Host and Network Name Lookups
After=network.target
diff --git a/units/nss-user-lookup.target b/units/nss-user-lookup.target
new file mode 100644
index 000000000..40e214897
--- /dev/null
+++ b/units/nss-user-lookup.target
@@ -0,0 +1,15 @@
+# This file is part of systemd.
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+
+# See systemd.special(7) for details
+
+# This exists mostly for implementations lacking socket/bus
+# activation.
+
+[Unit]
+Description=User and Group Name Lookups
+After=network.target
diff --git a/units/remote-fs-pre.target b/units/remote-fs-pre.target
index 8aceb08b9..eca271b3b 100644
--- a/units/remote-fs-pre.target
+++ b/units/remote-fs-pre.target
@@ -9,4 +9,4 @@
[Unit]
Description=Remote File Systems (Pre)
-After=network.target
+After=network.target nss-lookup.target
diff --git a/units/systemd-logind.service.in b/units/systemd-logind.service.in
index 531b8f7e9..48c1f2c3f 100644
--- a/units/systemd-logind.service.in
+++ b/units/systemd-logind.service.in
@@ -9,6 +9,7 @@
[Unit]
Description=Login Service
+After=nss-user-lookup.target
[Service]
ExecStart=@rootlibexecdir@/systemd-logind